Dreaded error 35868 and 35865


#1

Hi All.

I have a 1306B connected to a microcontroller. The micro boots the modem and all works well GPRS comms. However, at random periods I get dropped from the cellular network (don’t know why)resulting in various error codes. The dreaded 35868 error is causing me a lot of trouble as I appear unable to recover the Wavecom unless I cycle the power to the unit.

I have noted other people having this same problem. It would appear to be a Wavecom firmware issue. How do I solve this problem other than moving over to a alternative product (which is looking like the end result at present as a certain other product appears unaffected on same network).

Thanx
Brian


#2

As 35865 means the modem is not attached to the network, have you tried to do a “AT+CGATT=1”? Maybe after a “AT+CGATT=0” first.


#3

Tried the AT+CGATT=1 and nothing. Tried running through all bootup commands but no luck. Must always do a power cycle. Did not try AT+CGATT=0 though.

I Tried another network and modem lasted 6 hours before I got a new “internal failure” error message. My local Wavecom distributor brought me the new Fastrack Supreme 20 to try. Could not get that modem to work at all. So tomorrow I say goodbye to Wavecom and hello to Siemens.


#4

So you can have German bugs, instead of French ones… :wink:


#5

Let’s bug it out! :slight_smile:
How did you test your GPRS exactly?
35868 means that you were kicked from the GPRS, are you 100% sure that you are using the correct APN parameters, password…? I think wrong parameters could cause strange things depending on the GSM operator.

Cheers,
tom


#6

Hi …

Parameters used are correct and confirmed being correct. I have tested 4 different networks (with required settings) and I get similar results.

Being kicked from the GPRS network sounds correct. That is fine, but I do not want to do a total power cycle to get back on. An AT+ConnectionStart or an attach command ought to be good enough to get a connection up again.

The last internal error message did it for me. The end product is going to be sold world wide… and be configured for many networks. I cannot have a unit fall over due to Modem firmware issues.

This problem has been reported here as well …

nowsms.com/framer.htm?http:/ … 15913.html

Look for “Wavecom modem CME ERROR 35868”. The fix stated in that thread did not work.

Well a similar unit to what I have designed is using the French one. That unit is 100%. So hopefully the French bugs have all been fumigated.


#7

Hello,

The 1306B contains a q2406b gsm module, which i think a mature product by now. The initial versions may include many bugs, but i don’t think that the latest firmwares are too buggy. Which version did you try? If you didn’t order it specifically, probably you got a module with an old firmware.

tom


#8

Hi Tom.

Not sure what I was sold. Been playing some more and got another issue I can find no information about.

Sometimes when opening a socket, I get error 37122 (another internal application already running) I can find no detail as to why this is happening or how to resolve it. Anybody?

Brian