Wavecom Fasttrack 1208B


#1

Hi
I’m hoping some maybe able to advise on a problem I have using the wavecom 1208B modem and activeSMS

The setup is that this modem receives text messages then the activeSMS takes the information and dumps it into an SQL DB

The issue I have is that the modem will process some text messages then just stop with the following information

6/09/18 08:31:48 - RX: ATERROR
26/09/18 08:31:48 - EX: Protocol Exception raisedFunction: CATDevice::ResetConnectionDescription: AT command retruned ERRORHResult: -2147467259
26/09/18 08:31:48 - TR: CATTransport::ResetConnection - General Exception (AT command retruned ERROR)
26/09/18 08:31:48 - TR: CATTransport::ResetConnection - Enter
26/09/18 08:31:59 - TX: ATE1
26/09/18 08:31:59 - RX: ATE1ERROR
26/09/18 08:31:59 - TX: AT+CG
26/09/18 08:31:59 - RX: A
26/09/18 08:31:59 - RX: T+CG
26/09/18 08:32:00 - TX: MI
26/09/18 08:32:00 - RX: MIERROR
26/09/18 08:32:00 - TR: Device:
26/09/18 08:32:00 - TR: Using Default device settings
26/09/18 08:32:00 - TX: AT&F
26/09/18 08:32:00 - RX: AT&FERROR
26/09/18 08:32:00 - TX: AT
26/09/18 08:32:00 - RX: ATERROR
26/09/18 08:32:00 - EX: Protocol Exception raisedFunction: CATDevice::ResetConnectionDescription: AT command retruned ERRORHResult: -2147467259
26/09/18 08:32:00 - TR: CATTransport::ResetConnection - General Exception (AT command retruned ERROR)
26/09/18 08:32:00 - TX: AT
26/09/18 08:32:00 - RX: ATERROR
26/09/18 08:32:00 - EX: Protocol Exception raisedFunction: CATDevice::TestConnectionDescription: AT command retruned ERRORHResult: -2147467259
26/09/18 08:32:00 - IF: Port closed
26/09/18 08:32:00 - TR: CATTransport::Connect - General Exception (AT command retruned ERROR)

power cycling the modem then allows it to process a few more then it stops again

The current setup is 9600,8,N.1 no flow control, I did read somewhere that the wavecom modem supports auto baud, but I’m not sure if that is set, Or should it be set but to a higher baud rate than being used ?

any help appreciated

PhilS


#2

@PhilS18,

Auto baud is not recommended as it can be unreliable in operation, I would generically recommend hard setting the unit to 115200bps and not 9600. Re ‘ActiveSMS’ is this a PC package/tool you are using?

Key point, as with all modems is that you need to wait for the response to the previous command before trying to execute the next one, especially in older modems as the firmware might not have been particularily robust.

Regards

Matt


#3

Hi Matt
Thanks for the information, don’t suppose the commands to set the baud rate on the wavecom ?


#4

@PhilS18,

Do you mean what is the command to set he baud rate? If so then it is at+ipr=115200 as normal 3GPP specifications/all of the old and new units. You might need to send at&w afterwards as I do not know if this is automatically saved in flash.

Regards

Matt


#5

Hi Matt
Thanks for suppling the command, I have now set the baud to 115200, , Just have to wait and see how long it is be for it stops responding if it stops responding now


#6

it stopped after about 2 mins - this is the diag log, any Idea’s why ?

01/10/18 10:37:17 - TR: CATTransport::Connect - Enter
01/10/18 10:37:18 - TR: CATTransport::ResetConnection - Enter
01/10/18 10:37:18 - TX: ATE1
01/10/18 10:37:18 - RX: ATE1ERROR
01/10/18 10:37:18 - TX: AT+CG
01/10/18 10:37:18 - RX: A
01/10/18 10:37:18 - RX: T+CG
01/10/18 10:37:19 - TX: MI
01/10/18 10:37:19 - RX: MIERROR
01/10/18 10:37:19 - TR: Device:
01/10/18 10:37:19 - TR: Using Default device settings
01/10/18 10:37:19 - TX: AT&F
01/10/18 10:37:19 - RX: AT&FERROR
01/10/18 10:37:19 - TX: AT
01/10/18 10:37:19 - RX: ATERROR
01/10/18 10:37:19 - EX: Protocol Exception raisedFunction: CATDevice::ResetConnectionDescription: AT command retruned ERRORHResult: -2147467259
01/10/18 10:37:19 - TR: CATTransport::ResetConnection - General Exception (AT command retruned ERROR)
01/10/18 10:37:19 - TR: CATTransport::ResetConnection - Enter


#7

This is very Strange, it looks like the modem keeps reverting the settings to default, even though I have set the baud
rate, is there a command to stop this from happening ?
Phil


#8

@PhilS18,

So at&w should do it if it is not done automatically but if you end up sending at&f it will set it back. The unit is extremely old so difficult to predict (from a documentation/testing it point of view, it will behave consistently).

Regards

Matt