I have been trying to send sms using this newly bought wavecom GSM/GPRS modem but having no luck. I tried to google but so far haven’t been able to figure out. The modem is brand new. When i try the following command it gives me error: +CMS ERROR: 512



I know it must be somthing trivial i am missing here. Can someone help me please.

Thanks in advanace.



Which particular Wavecom modem? Have you looked up what +CMS ERROR: 512 means in the AT command guide? Or Googled it?

A quick google found this link which may be of use

BTW Wavecom was purchased by Sierra Wireless some years ago and as far as I’m aware Sierra Wireless stopped using the Wavecom brand on modems long ago.

ciao, Dave

thanks david. Yes i googled it and found out that its “MM establishment failure” or “user aborted” but i still haven’t been able to figure it out. I just purchased it last week from ebay.
The signal strength is also good.

Any other idea for troubleshooting?


As davidc says, the Wavecom name hasn’t been used for years - so this must be either a surplus unit, or possibly even a fake.

Post a link to the actual auction.

The trouble with buying on ebay is that you’re not going to get any support from the seller.

That means that your modem couldn’t communicate with the network

How did you determine that?

Is the unit correctly registered to the correct network?

If it’s a pre-paid SIM, does it have sufficient credit?

Does the SIM work in another unit?

Is the SMSC correctly configured?

I have ran the following command to check the signal strength using the following command
+CSQ: 20,0
The sim card is post paid and works on other phone. I even tried to insert another card which didn’t work either.

you guys might be right about the wavecom modem that it might be faulty unit. By the way i have just ordered the following modem “FXT009 MODEM, GSM / GPRS / EDGE, QUAD BAND”

I will just wait for the new unit to arrive by the way can you guys comment on the modem i have just ordered(FXT009) or can you recommend any other sierra modem. I need to use it for sending txt msgs.

Like a mobile phone, if the modem cannot register to its correct network, it will register in “Emergency Calls Only” mode to any available network; in this case, +CSQ is the signal from that network.

So a “good” CSQ result does not necessarily mean that you have SMS service - hence my question of whether it is correctly registered.

Being an old modem, it might be that you have to manually configure the Service Centre (SMSC).

Being a “surplus” modem, it might have been configured by previous user(s) to some bizarre settings.

If it’s a fake - well, who knows!!

You should really have discussed your requirements with the vendor before ordering - so that they could advise you on an appropriate choice :exclamation:

Yes, it should be fine for that.

As you guys said the unit looks like a fake unit. I have opened the case to see what module is inside and apparently it has no name on the module also it looks like the module was taken off from somewhere and soldered onto this board.

Waiting for the FXT009 to arrive.

Thanks again