Passthrough TTL

Is there any way to have the AirLink not decrement the TTL value on packets? I’m working w/ an RV50X and have tried IP passthrough mode but the device is still decrementing the TTL and showing as a hop when performing a traceroute. I need the device to essentially be transparent, pass the packets w/out modifying the TTL value.

Is there any way to accomplish this?

Hi @angmarketsinc,
I believe that is the expected behavior when using IP Passthrough in Airlink. Actually, When the gateway is in IP Passthrough, it is not performing full routing but there is still a “little” routing involved so the TTL is decremented to avoid any possibility of routing loops
Please tell me if you have any concerns and help tick Solution if your question is answered
Thanks

1 Like

Thanks for the reply, @Vianney. My use case requires the TTL to not be modified, that or manually adjusted so the AirLink does not show in the hop path.

I’m familiar w/ other devices s/a Mofi and they have an option to specifically modify or set the TTL so the LTE gateway/router is transparent from a TTL perspective. Was hoping I’d be able to accomplish that w/ the AirLink, but it does not appear to be the case.

My other option is going to be to artificially increment (+1) the TTL on the equipment to so the TTL decrement (-1) done by the AirLink essentially balances out to zero (0).

@SierraWireless, are there any plans to add this ability?

Thanks all!