Open at project for FX100


#1

Dear all, I am creating an open at application for the new airlink fx100 using develper studio. But in the hardware configuration (new open at project wizard), there is no option for this model. If i choose Fast Extrack, the resulted dwl file cannot be downloaded to modem since it complain the dwl file is not generated for Fx100. In “Auto detection”, FX100 can be detected and also which com port it is using. However, it cannot be checked, thus the wizard cannot be proceeded.

According to the DS relaease note, it can support FX100 ( iam using version of 2.3.1). I cannot find how to do it. Anyone can give some suggestion? Really appreciate the help. Thanks in advance!


#2

hi,

This seems to be strange! :astonished:

Developer Studio version 2.3.1 has option for FX100.
Also, while downloading the file you have to build it on the firmware corresponding to FX100.

And, you can add firmware packages for FX100 using Package manager tab.

Thanks :slight_smile:


#3

Hi Rex_alex

  I still cannot figure out how to have the option for FX100.

 The installer i am using is Open_AT_Application_Framework_v2-51_Full_Installer ( i think this is the latest one). I have tried to install it into another machine but with the same result.

I also try to install all new package from 

updatesite.sierrawireless.com/developerStudio
updatesite.sierrawireless.com/packages

except the one “Source for Open AT projects managemen”, which will give me an error like

An error occurred while collecting items to be installed
session context was:(profile=M2StudioProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Problems downloading artifact: osgi.bundle,com.wavecom.openat.ide.devenv.branding.source,2.3.1.201305211544-R11859.
Error reading signed content:C:\Users\llu\AppData\Local\Temp\signatureFile5847218063110553330.jar
An error occurred while processing the signatures for the file: C:\Users\llu\AppData\Local\Temp\signatureFile5847218063110553330

 After this updating, i still cannot see any option for FX100.


By the way, how to add firmware packages for FX100 using Package manager tab? Can you help to explain in more detail?


Many thanks for your kind help!

#4

Hi luiei,

it seems the Package is not installed in the developer studio.

Go to Packages Manager. In the left side i.e. In available packages section, Right click and add new repository. Provide the path to the package and install the same.
After that, you will be able to see the FX100 option in hardware section while creating the project.

Thanks


#5

Hi Rex_alex,

Thanks again for your help. But the problem is i donot know the path to FX100 package. How and where can i find the path?

Regards!

Luiei


#6

Hi,

Please contact your distributor /FAE for the same :slight_smile:

Thanks


#7

OK, will try that.
Thanks a lot!