OK after power on reset


#1

Hello all,

I stumbled into some strange behaviour of a modem.
Every time the unit is resetted with power off/on, it sends out “OK” on the serial port even though I’ve not sent any command and its even before “+WIND: 3”!!
It doesn’t matter if I got the serial port connected or not, or if flowcontrol is enabled/disabled.
However, the “OK” is not sent out after a “+CFUN=1”

It seems like it is caused by the fact that an OpenAT application has been running on the unit and later disabled.
But the “OK” does not disappear even if Open AT is disabled/deleted (+WOPEN=3, =4, and =0) or even if I download the whole GSM core firmware.

I’ve also tried to reconfigure every command I can think of that can cause somthing like this.

Unit is Q2406B with 6.41b and Open AT 2.10.

Anyone seen this before and know how to get rid of this unwanted “OK”?
Is this a Wavecom bug?
Is there a workaround?

/Snoooze


#2

I’m using FASTRACK modem ( M1306B )
and i have the same problem.
at the first start it show
WIND: 3
OK

for every period time. ( 2 or 3 sec )
Please Help!!!


#3

OK, then I’m not alone about this…

But My “OK” is sent out before the “+WIND3”

...Power on...

OK

+WIND: 3
.
.

/Snoooze


#4

I have found that the module will response “at+wbhv” with two "OK"s. This happened only to 651_09gg.

at+cgmr
651_09gg.Q2406B 1478872 070705 14:15
OK

///How come got two OK ???
at+wbhv=1,0
OK

OK


#5

Hi,

at power on, I have noticed the same result with the “OK”.

With “641b09gg.Q2406B 1339080 041604 16:04” I receive also the “OK” before the “+WIND: 3”.

But when I use an older version “640d09gg.Q2406B 1273604 091103 18:26” I got no “OK” before the “+WIND: 3”.

regards
skos


#6

hmm, interesting,

…and when you go back to the 6.41b you get the OK again, right?

Have you found out how to get rid of it?

Or have you found out what is causing it?

/Snoooze


#7

.

Yes, you can receive the OK again.

Maybe wavecom build in this OK, because a big customer need this message to detect anything. :question: :question: :question:

It could be similar to OpenAt 3.x with the at+wdwl/at+cfun=1 command.
There you have also a changed behaviour to OpenAt 2.x

regards
skos


#8

Hi,

This should be the bug of 6.41b firmware.
In 6.41c firmware release note there is stated “Correct Problem” : “OK is displayed when resetting the module”.

I tried 6.41c and get no extra “OK”, but not yet tried 6.5x