No serial Output


#1

Hello I’m a complete Newbie,
I have built a board with a Q2686, sim card and max3232. I have inverted both Rx/Tx and RTS/CTC thru the max3232.
All seems to work OK. It registers on the network and responds to AT commands. I have compiled the hello world program which downloads with no errors and have set it running. eg.

at+wopen=1
OK
þ
+WIND: 13
+WIND: 1
+WIND: 16
+WIND: 4
+WIND: 10,“SM”,1,“ON”,1,“EN”,0
+WIND: 11,“18BAFD8A21334EEF71E074CECD71C231”,“E9C8C132B36B7F101BE80F3F95C2D9E0”,“42F8CDA6A5E9A41CF15B161ADCD96113”,“0ECF79E83166E5C3CEC38FCE9800FF32”
+WIND: 7

However there is no serial or Trace output.
Is there something basic I am missing?
I have used both Open AT V2.30 and AT V2.21 with the same result
Any ideas would be appreciated
Mark


#2

Have you started the application - with AT+WOPEN=1 :question:


#3

#4

Oops! :blush:


#5

Is it Hello World example from OpenAT suite? Maybe you use incompatible firmware - try to reflash your module OS with firmware from your OpenAT distributive.
Also, describe the whole process of how you downloaded Hello World in your module.


#6

It seems that you use Hello World example from Oasis 2.30 which is compatible with OS R7.x. And Q2686 modules usually come with OS 4.xx. If you do not want to reflash the module download and use OpenAT SDK 4.26.


#7

I have downloaded both from M2Mstudio and from Hyperterminal using Xmodem1k. I have tried compiled versions using OS 6.30 and 6.21.
The modules firmware is R72a00gg.Q2686G
Which Open OS should I be using?

In the traces view there is no ADL replys but gives this ATI respsonse repeating at about 1 Hz

09/07/10,09:20:52:390 ATI 2 Rec RR_RXLEV_IND
09/07/10,09:20:52:390 ATI 4 02 00 19 00 04 00 82 25 33 29 00 00
09/07/10,09:20:53:734 ATI 2 Rec AT_TIM_REQ
09/07/10,09:20:53:734 ATI 4 ff ff ff ff 00 00 06 42
09/07/10,09:20:55:656 ATI 2 Rec AT_TIM_REQ
09/07/10,09:20:55:687 ATI 4 ff ff ff ff 00 00 06 42

Thanks for the help


#8

Sorted Thanks, found an article which said I required OS 6.11. Download that and its away.