"No Internet Access" with EM7565 + Issue with Windows 10 Driver

Hello Community,
I got 2 brand new EM7565 Sierrawireless modules for internet to my Windows 10 device.
Using Verizon and T-mobile Data SIM card.
at the start everything looks perfectly fine was able to detect the Sierra Wireless EM7565 Modem, COM port were assigned, all the derivers were installed. IP address got assigned from the Verizon / Tmobile. But I get ‘No Internet Access’ I tried to change the APN setting but nothing worked for both TMob and Verizon.
A support representative suggested to update the MBIM which might be the problem of ‘no internet access’ issue.
so as per the instructions I ran AT commands through Putty and update the Interface bitmask from 0000010D to 0000100D. and since i ran that command, Windows 10 started complaining about the driver and now it is not recognizing the driver, I uninstall and reinstalled all the drivers but no change.
with that unfortunately I can’t even go back and reverse the interface back to 0000010D because it is an unknown device and Putty wont connect.
I downloaded Sierrawireless Skylight but that is also not finding the EM7565 either
attached are the screenshots of before and after. GREATLY APPRECIATE any support and assistance.

Have you tried the following?


Unfortunately I am not able to connect to it anymore, since windows 10 is not able to recognize the driver.
so I cant tell if its 90b1.
do you think I can connect to the module any other way while windows 10 is not recognizing it anymore?

you can install Virtual machine for Linux and see what happens inside