EM7511 on CF-20 unable to load latest driver

I am having problems for the driver for EM7511 to load on a Windows 10 64 bit toughbook CF-20. When I download the latest build from Seirra website ( Windows Drivers for EM/MC Series Modules (Build 5087)) the toughbook doesn’t load a Seirra driver, but the windows driver for it. I have tried uninstalling and removing the device, etc. no luck. Anyone any ideas? Thank you. Arne

what do you mean by loading “the windows driver for it”?
Do you have screenshot of the device manager?

by loading the drivers I mean when I run the exe that I downloaded from Sierra website, it doesn’t set up the drivers for the EM7511. When I go into device manager I find the generic windows driver attached. See screenshots


Can the modem port be used with AT command communication?

Not sure what you are asking. Under modem it list Sierra Wireless WWAN Modem #2. The driver here is Sierra Wireless Incorporated with data of 4/22/2020 and version 20.4.1005.45.

We are using the toughbooks with ATT FirstNet SIM cards.

it is because you are using MBIM driver of Windows:

If you use RMNET instead of MBIM in AT!USBCOMP, then it will switch to Sierra driver.

I understand better now, but how do I make that change?

you can use tera term to connect to modem port and type:


After module reboots, it will show another Sierra driver

BTW, why don’t you just use the MBIM driver from Microsoft?

Thank you, I’ll give this a try.

I am not aware how I would obtain the MBIM Microsoft driver. I was assuming the best driver to use is the one from the vendor. We have had some issues with connectivity especially switching between Cellular and WIFI.