Need help with m1306b tcp stack


#1

Hi!
I am trying to develop an application for transferring data over gprs with wavecom fastrack m1306b
I can only use AT commands

I have a problem with the at+cgdata=1 command
It returns a No carrier response.
I checked at+cgpaddr=1 and i have an ip address (after at+cgact=1,1)

I would like to ask if it is because my modem does not hav a tcp stack

i have tried the at+wopen=1 command, but it makes no difference, I also can not use nor the at# commands, nor the at+WIP commands

edSoft-w302-v210 is what i need to use at# commands? Is this the tcp stack also?

i tried the command at+wcfm=2 an it returned 7 so i can use openat and gprs
i tried the command at+wcfm=5 and it returned 0, so i can not use at# commands

My question is
Can i obtain edsoft or wiplib? is it free?
after i download edsoft or wiplib on the modem will i be able to us at# or at+wip commands?
will this help on my at+cgdata=1 -> NO CARRIER probem?

Thank You!
Akos Csiszar


#2

My answer will not help to answer your no carrier problem but what I can tell is that the EDlib or WIP lib options are not free, you have to order TCP/IP enabled products which are a little more expensive than the ones that are not.

Downloading WIPlib or EDlib is not possible as they are librairies… and that therefore have to be linked to your code after compilation.

But if you want to access the IP stack with AT commands you can download WIPsoft which will provide AT + WIP commands or EDlib which will provide AT#. But I think Edlib is no longer supported by Wavecom.