MP70 WiFi AP not working when remote WiFi client mode can't connect to remote SSID

We just bought new MP70 devices to replace GX450s. I upgraded ALEOS to (latest), and the radio was already on the latest version. I am currently trying to configure these while working from home. I want to configure WiFi mode as “Both (AP+Client)”. These devices will be installed in Fire vehicles that do not get very good cell signal when parked inside the Fire Station. We also want them to have the WiFi hotspot for use while on-scene. If I set the WiFi mode to “Access Point (LAN)” I can connect my Win10 laptop to the MP70 AP hotspot and all works properly. When I set WiFi mode to “Both (AP+Client)” and add the “Remote AP” SSID for the AP at our Fire Station, which is not currently reachable, then my laptop no longer sees or connects to the AP hotspot, and the WiFi status light on the MP70 is off. If I add my home SSID to the 2nd “Remote AP”, which it connects to, then I can connect from my laptop again to the MP70 AP hotspot. I can connect my laptop to an MP70 Ethernet port in any of the above configs and have internet access.

I originally had SSID broadcast for MP70 AP disabled. I enabled it but did not help. I’ve also tried enabling traffic monitor, ping monitor, and WiFi RSSI monitor.

Any help resolving this issue would be greatly appreciated!

*EDIT - I have also tried changing AP mode to b/g/n 2.4GHz (from n/ac 5 GHz). I also tried a few different channels & widths in each setting. That did not help.

1 Like

Hi amacdonald,

Please try to set Security Authentication Type of Access Point (LAN) to open.

You can see the note mentioned in the latest software configuration doc on page 149.


Thank you for the suggestion, but changing that setting did not make a difference.

Personally I think that is a huge security issue if that setting is indeed required for that WiFi mode. The strange thing is that the MP70 AP works properly (with WPA2 AES PSK set) after the MP70 WiFi client has connected to my home WiFi AP. According to the example described on page 148 it is supposed to work the way we want.

I think it is a bug in ALEOS. If I add my Home WiFi AP as a remote site for client connection and reboot the MP70, the MP70 connects to my home WiFi and I can connect devices to the WiFi hotspot on the MP70. The WiFi indicator light on the MP70 turns amber indicating it is using my home WiFi for WAN connection. If I then turn off my home WiFi AP, the clients connected to the MP70 AP stay connected, and the MP70 indicator light turns green indicating it is using LTE for WAN connection. If I now reboot the MP70 while my home WiFi AP is still off, the WiFi indicator stays off and the MP70 AP SSID is not available. If I now turn my home WiFi AP back on, the WiFi indicator turns amber again, but the MP70 WiFi AP SSID is still not available.

Hi amacdonald,

I tried on my MP70 and faced the same issue. You could downgrade to the previous FW(4.14) to bypass this issue.

Please be patient and wait for the next fix from Sierra.


Hi jerdung,

I verified it works properly on ALEOS 4.14.0. Do you know if Sierra Wireless monitors this forum, or do I need to create an official support ticket for 4.15.0?

Thank you for your help!

Hi amacdonald,

I’m sorry, I shared you the wrong link. Actually, there was a similar bug reported to Sierra and the engineering team is looking into it. While waiting for it to be fixed, please use FW(4.14). I’ll let you know when the fix is available.


Jerdung, Thank you for the update!

Do you have a link to download v4.14? I don’t seem to have a copy and can’t find a way to download previous versions. I had updated 2 out of the 4 MP70s to 4.15 before I discovered the issue.

Hi amacdonald ,

You can download the firmware version MP70 4.14 here.

1 Like

Thank you for the link!

HI @amacdonald ,

Do you open the ticket to SWI technical support to solve your issue on FW 4.15? If yes, could you please share with me the ticket number?

If no. please let me know, I will guide you how to open the ticket.


Hi Jerdung,

I had sent an email from the link you previously posted, but then you said that wasn’t the correct link and removed it. I never heard back from the email I sent.

I have run into same issue today. As soon as I switch from LAN to both and reboot I loose ALL internet with or without setting any remote access information. I have to manually log into the MP70 to set it back to LAN. I talked with support and I guess they are not aware of the previous issue others have reported. As far as setting to OPEN, I agree, that make absolutely NO sense.

Hi amacdonald,

You could use the contact link below. Contact_Reason should be set as Other


Hi Jerdung & Newberryb,

I just submitted the request on the contact us form. I’ll post here with any feedback I receive.

I just found this link to submit a repair case. I posted it there as well.