MP70 connects to internet but I can't get to admin page to set up wifi settings

I got a replacement MP70 device for a device that was under warranty. Installed this device and it connects to Verizon service fine and when I connect my laptop directly to it, I can get to the internet just fine. However, I cannot connect to the the admin console so that I can set the wifi up. I am using an ethernet cable connection and going to as I have done with all my other devices.

Hi tshawver,

Can you access the MP70’s ACEmanager? Can you ping to from your laptop?


No, ACEmanager will not come up when trying to connect via ethernet with a browser to

Says something like “no connection” but I can hit the internet (e.g., yahoo) with no issues

Next time vehicle is available to me, I will try to ping the IP address. I plan to try to connect via USB with a browser to

Never had to try these methods before as ethernet has always worked with all our other vehicle modems with no issue.

Thanks… Tim

Hi tshawver,

Please try accessing ACEmanager with

HTTPS worked! Thanks for the help!

Hi tshawver,

Please help to tick “Solutions” as your question is answered.