most AT command will return error After update the software


#1

hi all

After update the software on my Fastrack Xtend with Embeded Software in M2MStudio, most AT command will return error except “AT” and “AT+WDWL”.
Could some one help me to recover the device? Thanks


#2

Reflash it with valid OS firmware.


#3

If you don’t know how to do that, then talk to your Distributor about it!

While you’re talking to them, you should also find out what training and support they can offer - and make use of it!

Whenever you embark on any development like this, you should always take care to select a distributor/supplier that is going to be able to provide you with adequate support.
If you don’t have the expertise in-house, consider hring a consultant - at least to get you started…


#4

That is because it is still in downloader mode. Once you upgraded firmware, you have to execute AT+CFUN=1 to get it back to normal mode.

Rudolf


#5

Same problem: I have a FXT003 and the only AT commands working are:
AT
AT+WDWL
I think I downloaded a wrong firmware and I don’t know the good firmware to download now and get my fastrack xtend fxt003 work.
Before, the modem seemed to work, I was able to enter more AT commands, like these for the general purpose I/O.
Which file I have do download now? With dwlwin? With Developer Studio? With a terminal and 1k Xmodem?
I tried many of these possibilities, but nothing works. No help with the documentation, including the Firmware 7.45 Release Notes, recovery instructions,…
Nothing happens with the command AT+CFUN=1.
I am looking for something called “OS firmware” or so, downloadable via dwlwin, Developer Studio or 1k Xmodem.


#6

I hope I fixed it!
I had to make a “special cable” to connect the FXT003 to the PC. It has the same wiring as the 15-pin <-> 9 pin cable delivered with the FXT003 box PLUS a 10 kohm resistor between the pin Nr3 of the 15-pin connector (BOOT) and the ground.
With this cable, dwlwin works (first launch dwlwin, then switch the power on the modem).
With this, I can download the bootloader and the firmware (7.44 version).
At this point,the AT commands work fine.
And after that with Developer Studion, I can begin to manage my project.
Just now, the “LUA interactive shell” works.

This has been done thanks to this forum and his contributors. The Sierra and Wavecom documentation is difficult to use. As we say in French:
“Why to make it simple when it is so easy to make it complicated”.