Modem firmware update


#1

I need to upgrade firmware and application on a lot of sierra modems.
The tuple of os, osloader, bootloader should be strictly aligned? If I will os 6.51 on a box I need the osloader, bootloader that are bundled in the same framework package?

Actually I download the following files:
BOOTLOADER=$OS_FW_PATH/swift/dwl.dwl
OSLOADER=$OS_FW_PATH/swift/w.dwl
OS_FW1=$OS_FW_PATH/R${FW_MAJ_VER}_fxt009.dwl
is correct?

What are files in swift direcory ? In example com.wavecom.openat.ide.spm.fw.model.7.51.0.201205311751_7.51.0.201205311751/resources/swift/fxt009.dwl
for an update I need to download this file too on the box?

I see that in 6.51 there is no more support for fsu004, or at least the file R7.51.0_fsu004.dwl is missing. There is a way to let an newly recompiled (on 6.51) app on this kind of boxes?

thanks,
Luca


#2

Hi,

The correct sequence to upgrade the firmware :

1.dwl.dwl
2. R7.51.0_fxt009
3.w.dwl

And,it is not needed to download the file in the swift directory also.

Thanks.


#3

Hello,

Can you explain what is the file w.dwl ?
Or is there any documentation about this file ?

Thanks.
Marc


#4

thanks!

what about compatibility:
can I use os 6.51.0.201206010944 with fw 7.47.4.201208311102 ?

thanks
Luca