Mobile Broadband

Hey all,

I have “MC8790V” currently my application uses a dial up connection to download over 3G, however I wanted to move it forward and start using windows mobile broadband API. I had a little test application working a few months back, left it to one side and came back to it today however cant seem to connect just through windows mobile device broadband(no application involved) it used to show the available connections the same way wireless Lan did but show networks"EE", “02”, “Three”. It still shows up under network connections as “Mobile Broadband connection”( Not connected) If i run the watcher which I don’t want use, it connects to 3G and the mobile “Mobile Broadband connection” says unidentified network andI have internet and able to download.

I ran netsh mbn show interfeaces which returns there is no mobile broadband interfaces.

Bit if i run
wmic nic get NetConnectionID it returns Local area Connection, Mobile Broadband connection and wireless netowork connection

I know it can connect this way, just really frustrating
Hope you guys and girls can help.

Thank you in advance.


According to me, you might be getting Sierra wireless HSPA network adaptor in the adaptors list.
Could you please check the device manager? Could yu find any mobile broadband network adaptor or is it HSPA networka adaptor?


Hi Rex_alex,
Thank you very much for the reply.

Under device manger I have;


  • Sierra Wireless HSPA Modem

Network Adaptors

  • Sierra Wireless HSPA Network adaptor
  • Plus a lot of WAN mini port stuff


USB controllers

  • Sierra Wireless HSPA Device

I just booted up another computer with the same device in and works on Mobile broadband but I could not see anything under device manager referring to mobile broadband on it. Most likely a setting I have changed somewhere causing this unit not to work. :frowning:

Thank you again.

Been comparing the Device managers on both computers, the differences iv seen so far is that the one that is working has 4 Sierra wireless HSPA Devices under “USB controllers” in device manager and the non working mobile broadband computer only has 1, most likely nothing but it is something I noticed.

Still trying to solve this, reinstalled windows and the problem still there im thinking it could be something to do with the firmware. Is there a way of flashing them?

You can get the latest firmware from the FAE/Distributor.
I think if you try with watcher, it will use the same adaptor what u can see in the device manager. It may be like, after connecting thru watcher… after some time it should show as connected and not “un identified network”

Thanks again for replaying Rex_alex, i tried installing firmware which works on other computers with the same adapter with no change.

When i connect through the watcher the watcher is fully connected and it shows what network it is on and i can surf the Internet.

While the watcher is connected the windows icon at the bottom right corner doesn’t show it connect and if you click it it doesn’t show any GPRS connections to connect to.

If I go to network connections it shows the mobile broadband connection as “unidentified”