MG90 LTE-A Reset to Factory Default not working

Has anyone else had problems with the MG90 LTE-A part # 1102695 Reset to factory default settings not working?
Here is what I tried with no luck, things actually got worse when I tried the back reprogram/reset button.
After about 15 seconds of having the recessed Reset button near the cellular modem closure depressed, all the LEDs will quickly flash white, but did not stay white and reset the router config back to a default out-of-the-box type settings. It did not power off either. After waiting a couple minutes, I went ahead and just manually powered down the MG90, but still no luck.

I tried many different time periods of having that MG90 Reset button depressed such as 15s, 30s, 1min, 3min, and even 7 minutes with no results - still no solid white LEDs, power off, and associated factory reset to default values. By the way, 2 of the objects I used to depress that reset button were more than small enough for that little hole; so the button was fully depressed.

Since the front Reset button on the MG90 did not function properly to create a reset to factory defaults, I then tried the back reprogram/Reset button which created another problem. After depressing it for ~30 seconds, all communications with the MG90 were lost; so I disconnected power. Still no comms after plugging back the power cord; so I couldn’t even see the MG90 login website.
I redid this for about a minute the 2nd time, but again still no login website, nothing.
Anybody else had to reset an MG90 and noticed that the Reset function does not work with some MG90s?
Thanks

Hi @TJusingSierra,
The attached video shows the factory reset procedure that I have just tried successfully on our device. To reset the router to the factory default settings:

  1. On the front of the unit, press the Reset button for the ‘Button Reset Time’
    configured in the LCI’s General > Shutdown tab (factory default is 10 seconds). I guess you cannot check this because you are not able to access the web. You can try the default timeout 10s
  2. When all the LEDs turn solid white, release the Reset button.
    When the factory reset is complete, the MG90 powers off and, if AutoPower is
    enabled (LCI General > Startup tab), will reboot.
    -Plug an ethernet cable in port 1 after the device come back like image.

Connect device to a window machine then change
image

Try to go web as below

Please try and share any concern you have. The forum limits the size of uploaded file so please download the attachment then delete .7z then unzip them. Sorry for this inconvenience
MG90 factory-reset.zip.004.7z (1.2 MB)
MG90 factory-reset.zip.001.7z (4 MB)
MG90 factory-reset.zip.003.7z (4 MB) MG90 factory-reset.zip.002.7z (4 MB)

Hello Vianney,
I downloaded those 4 zipped files; however, I was not able to open them. Double-clicking on one of them brings up NewZip - WinZip Enterprise which gives this error:
image

I looked in our approved folder list of downloadable software, but 7-Zip is not there. I like it and use it on my personal computer; however due to not being approved or know of here, I cannot use it. Either way though, I went through the MG90 Reset procedure Many times, but Never saw the LEDs turn Solid white. Nor did it power off or power cycle likely due to the Reset function, or button, Not working.

Fortunately, I was able to access the MG90 by trying variants of the MG90 password in the lab. Whoever, assigned it from another project had just added a “1” to the default; so I got LUCKY since there is no label or documentation of it, and this MG90 LTE-A Reset function does NOT work.

Thanks much for the effort and Helpful details you put into your good response here Vianney.
From this bad experience, I am thinking I should check all new MG90 routers to see if the Reset button function works going forward.
Thanks A Lot!
TJ