MG90 - unable to upgrade firmware or factory reset

Hello all,

I’m new here and I’m hoping someone can help me. I have a MG90 router that I’m unable to upgrade the firmware or factory reset. I’m also unable to access the admin page to login to the router.
When I plug it in, the power LED rapidly flashes red several times, then it slowly flashes green 5 times, it will continue repeating this pattern until I unplug it.
Reference this 30 second video of the LED flashes.
Can anyone tell me what I need to do to resolve this issue? I’ve tried factory resetting the unit by holding the Reset button on the front for 10 sec, 30 sec, 1 minute…etc. I’ve attempted to reset it numerous times and can never get all LED’s to change to solid white indicating it’s resetting. Any help would be appreciated. Thank you!

Hi @barkern,
Welcome you to our community!
According to the behavior of the LEDs in your description, I think the issue is caused by your power supply
How many volts are you using? if less than 11V, Please try using power supply more than 11V
Do the issue still happen in this case?


Good morning,

Thank you for the reply. This unit was originally in one of our EMS units, the LED operation was the same. I brought the unit back to my office to test with the power supply here hoping I could factory reset or upgrade the firmware, but per my video the LED operation is still the same.
I have another MG90 that works fine when plugged into the power supply at my office.
I’m not sure how many volts I am using, but I will check. Thank you!