MC8705 AT+CREG? returns ERROR


#1

Hi, all

I am using MC8705 and periodically get to the point where it will not respond to AT+CREG?
Responce is “ERROR”.
AT+COPS? returns 0,0,.“Limited Service”,2
Usually, I have to turn power off, then back on, but now have one that is constantly in this mode.
Simple system reset does not help (card is installed into embedded PC running Linux).

Any ideas?

Thanks,
Rudolf


#2

Just a note – MC8705 seem to do exactly that when SIM is not present. SIM is present in my case, but is there any way of checking the SIM with AT comamnds? Same SIm works fine in mobile phone.

Rudolf


#3

What is the extended error code?

What about AT+COPS=?

AT+CSQ

“Limited Service” sounds like “Emergency Service Only” :question:

What do the +WIND: indications tell you?


#4

https://forum.sierrawireless.com/t/gsm-network-problem/4906/4

https://forum.sierrawireless.com/t/undocumented-side-effect-of-at-cops-0/4871/1


#5

MC8705 does not run OpenAT. It is a cPCIE wireless module produced by Sierra Wireless, not by Wavecom.

AT+CSQ returns normal signal quality.

Rudolf


#6

Extended Error Codes are a standard GSM feature;

I have a feeling that AT+COPS=0 might also be standard.

Selecting a normally “not-allowed” network for Emergency Service Only when no “home” or “roaming” network is available is standard.

AT+COPS=? will show you available networks.

Most manufacturers have an equivalent means of proprietary, extended status indication - like +WIND:


#7

I would check SIM status before you check network status.
AT+CPIN? will give you more information about SIM status.


#8

Hi,
I have smiliar problem with MC8705.
I also have SIM card and want to access data network using MC8705.
The SIM card work well because I confirmed that data network accessible when I put the SIM into normal phone.
I just changed APN.
So I put the SIM card and MC8705 to PCB and set APN using AT+CGDCONT=1,“IP”,“APN”
But when I checked AT+CREG, AT+COPS, I got negative answer
AT+CREG?
+CREG: 0,2
AT+COPS
+COPS: 0
AT+CSQ
+CSQ: 99, 0
AT+CPIN?
+CPIN: READY

Does MC8705 has problem?


#9

I think you should try

AT+COPS=0

to init the network registration

Kindest regards


#10

Note the description of CREG in the AT Command user guide:

You can’t use this command to enable or disable GSM registration, only view indications on the registration status. Use AT+CFUN to set the modem functionality.