Weird behaviour of Verizon SIM on MC7455


I am facing a weird behaviour when using Verizon SIM with MC7455. I have flashed the verizon firmware from Sierra. The firmware version is as follows:

Manufacturer: Sierra Wireless, Incorporated
Model: MC7455
Revision: SWI9X30C_02.24.05.06 r7040 CARMD-EV-FRMWR2 2017/05/19 06:23:09
MEID: A000006CF194E9
ESN: 12813463286, 80CD6EF6
IMEI: 359072061147894
FSN: LQ727390940310

I am using ofono to establish a cellular connection. The ofono is not able to detect the SIM. The logs are as follows:
• /usr/lib/ofono/test/list-modems
[ /sierra_0 ]
Type = hardware
Model = MC7455
Manufacturer = Sierra Wireless, Incorporated
Lockdown = 0
Interfaces = org.ofono.SimManager org.ofono.VoiceCallManager
Serial = 359072061147894
Revision = SWI9X30C_02.24.05.06 r7040 CARMD-EV-FRMWR2 2017/05/19 06:23:09
Online = 0
Emergency = 0
Features = sim
Powered = 1
[ org.ofono.SimManager ]
Present = 0
[ org.ofono.VoiceCallManager ]
EmergencyNumbers = 08 000 999 110 112 911 118 119

As a next step, I tried to check the responses of AT commands:


+COPS: (2,“Verizon Wireless”,“VZW”,“311480”,7),(1,“AT&T”,“AT&T”,“310410”,7),(1,)

+CREG: 0,3

From the response of at+creg? we can see that the registration to the network is denied. I thought that’s the problem.

But when i tried to use qmilci tools, I can successfully register to the network and can also access the internet connection. The steps followed are as foloows:

qmicli -d /dev/cdc-wdm1 --dms-set-operating-mode=online
[/dev/cdc-wdm1] Operating mode set successfully

qmi-network /dev/cdc-wdm1 start
Loading profile at /etc/qmi-network.conf…
APN: vzwinternet
APN user: unset
APN password: unset
qmi-proxy: no
Checking data format with 'qmicli -d /dev/cdc-wdm1 --wda-get-data-format '…
Device link layer protocol retrieved: raw-ip
Getting expected data format with ‘qmicli -d /dev/cdc-wdm1 --get-expected-data-f ormat’…
Expected link layer protocol retrieved: 802-3
Updating kernel link layer protocol with ‘qmicli -d /dev/cdc-wdm1 --set-expected -data-format=raw-ip’…
Kernel link layer protocol updated
Starting network with 'qmicli -d /dev/cdc-wdm1 --wds-start-network=apn=‘vzwinternet’ --client-no-release-cid '…
Saving state at /tmp/qmi-network-state-cdc-wdm1… (CID: 35)
Saving state at /tmp/qmi-network-state-cdc-wdm1… (PDH: 63831232)
Network started successfully
root@alen-eval-kit:~# qmicli -d /dev/cdc-wdm1 --wds-get-current-settings
[/dev/cdc-wdm1] Current settings retrieved:
IP Family: IPv4
IPv4 address:
IPv4 subnet mask:
IPv4 gateway address:
IPv4 primary DNS:
IPv4 secondary DNS:
MTU: 1428
Domains: none
root@alen-eval-kit:~# ifconfig wwan1 netmask
root@alen-eval-kit:~# route add default gw wwan1
root@alen-eval-kit:~# echo “nameserver” > /etc/resolv.conf
root@alen-eval-kit:~# echo “nameserver” >> /etc/resolv.conf
root@alen-eval-kit:~# wget
Connecting to (
index.html 100% |*******************************| 13346 0:00:00 ETA

I am puzzled why the network registration fails with AT commands and when using qmicli I could successfully connect to the internet. Any information on this topic would be helpful.

Thanks & Regards


The COPS command indicates that Verizon is the currently selected network and that it is registered. The CREG state indicates the circuit switched attach state where the IP connection needs to be packet switch attached which are indicated by the AT+CGREG? and AT+CEREG? commands. If you check these two out I susect you will find that at least one of them is showing 0,1 as a state.