MC7455 registering to Verizon LTE network issue


#1

Hi,

I am using MC7455 for IOT projects and I am testing the functionality with Verizon network. Ofono and connman is used for establishing cellular connection.

Since MC7455 doesn’t support CDMA which Verizon uses when falling back to 3G , I set the mode preference only to LTE mode. I am seeing that the MODEM is not able to register to the Verizon network. When I tested the same SIM card with my iphone it registers to the network without any issues.

I have the following firmware installed in MC7455:

ati
Manufacturer: Sierra Wireless, Incorporated
Model: MC7455
Revision: SWI9X30C_02.24.05.06 r7040 CARMD-EV-FRMWR2 2017/05/19 06:23:09
MEID: A000007CBDA635
ESN: 12800775964, 800BD71C
IMEI: 359072061147894
IMEI SV: 12
FSN: LQ727390940310
+GCAP: +CGSM

at!gobiimpref?
!GOBIIMPREF:
preferred fw version: 02.24.05.06
preferred carrier name: VERIZON
preferred config name: VERIZON_002.034_000
current fw version: 02.24.05.06
current carrier name: VERIZON
current config name: VERIZON_002.034_000

The signal strength is as follows:

qmicli -d /dev/cdc-wdm1 --nas-get-signal-strength
[/dev/cdc-wdm1] Successfully got signal strength
Current:
Network ‘lte’: ‘-79 dBm’
RSSI:
Network ‘lte’: ‘-79 dBm’
ECIO:
Network ‘lte’: ‘-2.5 dBm’
IO: ‘-106 dBm’
SINR (8): ‘9.0 dB’
RSRQ:
Network ‘lte’: ‘-14 dB’
SNR:
Network ‘lte’: ‘9.4 dB’
RSRP:
Network ‘lte’: ‘-112 dBm’

System selection preference:

qmicli -d /dev/cdc-wdm1 --nas-get-system-selection-preference
[/dev/cdc-wdm1] Successfully got system selection preference
Emergency mode: ‘no’
Mode preference: ‘lte’
Band preference: ‘wcdma-2100, wcdma-pcs-1900, wcdma-dcs-1800, wcdma-1700-us, wcdma-850-us, wcdma-900’
LTE band preference: ‘2, 4, 5, 13’
TD-SCDMA band preference: ‘(null)’
Roaming preference: ‘any’
Network selection preference: ‘automatic’
Service domain preference: ‘cs-ps’
Service selection preference: ‘automatic’

I ran a field test on my iPhone here which is also connecting on LTE and it says that it is connecting on E-UTRA band 4.
I am seeing that the modem is using eutran-2

[/dev/cdc-wdm1] Successfully got RF band info
Radio Interface: ‘lte’
Active Band Class: ‘eutran-2’
Active Channel: ‘1125’

I tried to force the selection to band 4 with the following AT commands,

AT!ENTERCND=“A710”
at!DAFTMACT
at!dasband=42

Still I didn’t see any successful registration to Verizon network. Any information on these topics would be helpful.

Thanks & Regards,
Vinothkumar


#2

Don’t force it that way. use at!band


#3

Hi,

I am trying to set BAND4 using the at!band command.

From the output of at!band=? , I am seeing there is two Band 4 information available. What is the difference between the two and which mask should I take ?

at!band=?
Index, Name, GW Band Mask L Band Mask TDS Band Mask
00, All bands 0002000007C00000 00000100330818DF 0000000000000000
01, Europe 3G 0002000000400000 0000000000000000 0000000000000000
02, North America 3G 0000000004800000 0000000000000000 0000000000000000
06, Europe 0002000000400000 00000000000800C5 0000000000000000
07, North America 0000000004800000 000000000300185A 0000000000000000
08, WCDMA ALL 0002000007C00000 0000000000000000 0000000000000000
09, LTE ALL 0000000000000000 00000100330818DF 0000000000000000

                                               0000010000000000 - B41    
                                               0000000020000000 - B30    
                                               0000000010000000 - B29    
                                               0000000002000000 - B26    
                                               0000000001000000 - B25    
                                               0000000000080000 - B20    
                                               0000000000001000 - B13    
                                               0000000000000800 - B12    
                                               0000000000000080 - B8     
                                               0000000000000040 - B7     
                                               0000000000000010 - B5     
                                               **0000000000000008 - B4**     
                                               0000000000000004 - B3     
                                               0000000000000002 - B2     
                                               0000000000000001 - B1     
                              0002000000000000 - B8  (900)
                              0000000004000000 - B5  (850)
                              **0000000002000000 - B4 (1700)**
                              0000000001000000 - B3 (1700)
                              0000000000800000 - B2 (1900)
                              0000000000400000 - B1 (2100)

OK

I tried setting,

• at!band=10,“verizonB4”,0,8
• at!band=10

There was no error in setting the band, but still the SIM is not getting registered to the network.

Is it the correct way to set the band4 ?


EM7455 does not list Band 30 as valid AT!BAND
#4

Hi,

The above formatting messes the output up. In a normal terminal you will see the columns aligned correctly so the first column, the ‘GW band mask’ is for the 3G bands, the second ‘L band mask’ for LTE and the third ‘TDC band mask’ for TD-SCDMA.

As per the command manual the format of the command is

AT!BAND=,””,[,,][,]

So to enable Verizon LTE band 4 you could use the below command, hopefully that will work.

at!band=10,"VZWB4",0,8,0
at!reset

If you then force a search with at+cops=? then you can see what networks are visible to you (it will take a couple of minutes).

Regards

Matt


#5

Hi Vinothkumar,

depending on what you did with ofono/connman you may have overwritten
the data profile used for the EPS attach with an incorrect value which
causes the Verizon network to reject the EPS attach.

If you see the Verizon network listed in AT+COPS? or
qmicli -d /dev/cdc-wdm0 --nas-network-scan output please crosscheck
the AT+CGDCONT? output with another MC7455 with the Verizon Gobi image
which has not been used with ofono.

Regards,
Reinhard


#6

thanks for the details


#7

HI All,

Thanks rspmn and mlw for the information and details .

I finally managed to get my sim card register to the verizon network by reseting it to Factory-calibrated configuration.

It seems I badly screwed up the device using AT commands, it didn’t even work when I forced it to BAND 4 even though AT+COPS=? shows the Verizon network as available and as home network.

I used the following AT commands for reference :

at!entercnd=“A710”
at!RMARESET=1
at!reset

After entering the commands, I powered off the device completely and waited for few seconds before powering it on. The MC7455 didn’t get identified immediately, it took few seconds (around 30+) before I see the module getting attached as USB device. Once the module is up, it successfully registered to the Verizon network without any major issues.

Thanks & Regards,
vinoth