MC7455 T-Mobile, cannot connect when BAND=09 (LTE ALL)


#1

Hi,

We have two sets of SIMs from T-Mobile. The first set has static IP with APN=b2b.tmobile.com. The second set has static IP with APN=b2b.static.

We have started using MC7455 with GoldenOrb ROOter, but ran into an issue with LTE access and the second set of SIM cards (APN=b2b.static). So I moved over to Ubuntu and mbimcli to see if I could understand more of what is happening.

  1. If I set the MC7455 band to LTE All (AT!BAND=09), I get a message about not registered when attempting to connect.

sudo mbimcli -d /dev/cdc-wdm0 --connect=apn=‘b2b.static’ --no-open=4 --no-close
error: operation failed: NotRegistered
[/dev/cdc-wdm0] Session not closed:
TRID: ‘5’

  1. If I set the MC7455 band to All bands (AT!BAND=00), it connects fine. At issue is the radio access is UMTS / HSPA+. We would like the ability to use LTE where available.

goober@sierra:~$ sudo mbimcli -d /dev/cdc-wdm0 --connect=apn=‘b2b.static’ --no-open=5 --no-close
[/dev/cdc-wdm0] Successfully connected

[/dev/cdc-wdm0] Connection status:
Session ID: ‘0’
Activation state: ‘activated’
Voice call state: ‘none’
IP type: ‘ipv4’
Context type: ‘internet’
Network error: ‘unknown’

[/dev/cdc-wdm0] IPv4 configuration available: ‘address, gateway, dns, mtu’
IP [0]: ‘xx.xx.77.77/28’
Gateway: ‘xx.xx.77.57’
DNS [0]: ‘10.77.xx.xx’
DNS [1]: ‘10.77.xx.xx’
MTU: ‘1500’

[/dev/cdc-wdm0] IPv6 configuration available: ‘none’
[/dev/cdc-wdm0] Session not closed:
TRID: ‘7’

  1. The original set of SIMs with APN=b2b.tmobile.com does not have this issue. The modems connect straight-away with LTE access.

  2. The MC7455 firmware:

AT!image?
TYPE SLOT STATUS LRU FAILURES UNIQUE_ID BUILD_ID
FW 1 GOOD 1 0 0 ?? 02.30.01.01?
FW 2 EMPTY 0 0 0
FW 3 EMPTY 0 0 0
FW 4 EMPTY 0 0 0
Max FW images: 4
Active FW image is at slot 1

TYPE SLOT STATUS LRU FAILURES UNIQUE_ID BUILD_ID
PRI FF GOOD 0 0 0 002.045_001 02.30.01.01_GENERIC
Max PRI images: 50

Any suggestions on where to go next? I can try contacting T-Mobile for help, too. I’m just not looking forward to it :). I also don’t know where to start looking (SIM, APN, modem, mbim, etc.)

Best Regards,
g00ber


#2

@g00ber,

You have given a lot of good information above but lets stick to one format to make sure everything is in context and we can pin down where the issue is. Can you send the below AT commands to the unit (in this order)?

at+cmee=1
ati
at!priid?
at+cpin?
at+cimi
at+cgdcont?
at+cgpaddr=1
at+cops?
at!band?
at+cops=?      //This one will take a minute or two to complete
at+cops=1,2,"xxxxxx",7  //Replace the xxxxxx with the MCC/MNC for T mobile from the response to the above
at!entercnd="A710"
at!priid?

Regards

Matt


#3

Oh yeah stick an at!gstatus? at the beginning and the end as well plus an at+cops=0 right at the very end.


#4

@mlw ,

Thank you. I have executed the AT commands per your instructions. For both runs below, it was the same hardware and same SIM. I unplugged, plugged-in the MC7455 (via USB adapter) before each run. The APN=b2b.static.

***  AT commands as provided (radio access technology = 7) ***

at!gstatus?
!GSTATUS: 
Current Time:  58               Temperature: 31
Reset Counter: 1                Mode:        ONLINE         
System mode:   LTE              PS state:    Not attached 
LTE band:      No band          LTE bw:      1.4 MHz 
LTE Rx chan:   0                LTE Tx chan: 4294967295
LTE CA state:  NOT ASSIGNED
EMM state:     Deregistered     No Cell        
RRC state:     RRC Idle       
IMS reg state: No Srv  

PCC RxM RSSI:  0                RSRP (dBm):  0
PCC RxD RSSI:  0                RSRP (dBm):  0
Tx Power:      --               TAC:         FFFF (65535)
RSRQ (dB):     0.0              Cell ID:     FFFFFFFF (4294967295)
SINR (dB):     


OK
at+cmee=1
OK
ati
Manufacturer: Sierra Wireless, Incorporated
Model: MC7455
Revision: SWI9X30C_02.30.01.01 r7792 CARMD-EV-FRMWR2 2018/07/13 02:24:52
MEID: 35907206051099
IMEI: 359072060510993
IMEI SV: 16
FSN: LQ652440190310
+GCAP: +CGSM,+DS,+ES


OK
at!priid?
PRI Part Number: 9904514
Revision: 001.006
Customer: Generic-M2M

Carrier PRI: 9999999_9904609_SWI9X30C_02.30.01.01_00_GENERIC_002.045_001

OK
at+cpin?
+CPIN: READY

OK
at+cimi
310260148577996

OK
at+cgdcont?
+CGDCONT: 1,"IPV4V6","b2b.static","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0

OK
at+cgpaddr=1
+CGPADDR: 1,0.0.0.0,0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0

OK
at+cops?
+cops: 0,0,"T-Mobile",2

OK
at!band?
Index, Name
00, All bands


OK
at+cops=?
+cops: (1,"T-Mobile","T-Mobile","310260",7),(2,"T-Mobile","T-Mobile","310260",2),(1,"AT&T","AT&T","310410",7),(1,"Verizon","Veriz)

OK
at+cops=1,2,"310260",7
+CME ERROR: 30
at!entercnd="A710"
OK
at!priid?
PRI Part Number: 9904514
Revision: 001.006
Customer: Generic-M2M

Carrier PRI: 9999999_9904609_SWI9X30C_02.30.01.01_00_GENERIC_002.045_001

OK
at!gstatus?
!GSTATUS: 
Current Time:  368              Temperature: 31
Reset Counter: 1                Mode:        ONLINE         
System mode:   LTE              PS state:    Not attached 
LTE band:      No band          LTE bw:      1.4 MHz 
LTE Rx chan:   0                LTE Tx chan: 4294967295
LTE CA state:  NOT ASSIGNED
EMM state:     Deregistered     Attach Needed  
RRC state:     RRC Idle       
IMS reg state: No Srv  

PCC RxM RSSI:  0                RSRP (dBm):  0
PCC RxD RSSI:  0                RSRP (dBm):  0
Tx Power:      --               TAC:         FFFF (65535)
RSRQ (dB):     0.0              Cell ID:     FFFFFFFF (4294967295)
SINR (dB):     

*** Same run, now with radio access technology = 2 ***

at!gstatus?
!GSTATUS: 
Current Time:  174              Temperature: 28
Reset Counter: 1                Mode:        ONLINE         
System mode:   WCDMA            PS state:    Attached     
WCDMA band:    WCDMA 1700 
WCDMA channel: 1539
MM (CS) state: IDLE             NORMAL SERVICE 

WCDMA L1 state:L1M_PCH_SLEEP    LAC:           65EE (26094)
RRC state:   DISCONNECTED       UTRAN Cell ID: 06471F2D (105324333)
RxM RSSI C0:   -80              RxD RSSI C0:  --- 
RxM RSSI C1:    ---             RxD RSSI C1:  --- 


OK
at+cmee=1
OK
ati
Manufacturer: Sierra Wireless, Incorporated
Model: MC7455
Revision: SWI9X30C_02.30.01.01 r7792 CARMD-EV-FRMWR2 2018/07/13 02:24:52
MEID: 35907206051099
IMEI: 359072060510993
IMEI SV: 16
FSN: LQ652440190310
+GCAP: +CGSM,+DS,+ES


OK
at!priid?
PRI Part Number: 9904514
Revision: 001.006
Customer: Generic-M2M

Carrier PRI: 9999999_9904609_SWI9X30C_02.30.01.01_00_GENERIC_002.045_001

OK
at+cpin?
+CPIN: READY

OK
at+cimi
310260148577996

OK
at+cgdcont?
+CGDCONT: 1,"IPV4V6","b2b.static","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0

OK
at+cgpaddr=1
+CGPADDR: 1,0.0.0.0,0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0

OK
at+cops?
+cops: 0,0,"T-Mobile",2

OK
at!band?
Index, Name
00, All bands


OK
at+cops=?
+cops: (1,"T-Mobile","T-Mobile","310260",7),(2,"T-Mobile","T-Mobile","310260",2),(1,"312 530","312 530","312530",7),(1,"313 100",)

OK
at+cops=1,2,"310260",2
OK
at!entercnd="A710"
OK
at!priid?
PRI Part Number: 9904514
Revision: 001.006
Customer: Generic-M2M

Carrier PRI: 9999999_9904609_SWI9X30C_02.30.01.01_00_GENERIC_002.045_001

OK
at!gstatus?
!GSTATUS: 
Current Time:  365              Temperature: 29
Reset Counter: 1                Mode:        ONLINE         
System mode:   WCDMA            PS state:    Attached     
WCDMA band:    WCDMA 1900 
WCDMA channel: 9737
MM (CS) state: IDLE             NORMAL SERVICE 

WCDMA L1 state:L1M_PCH_SLEEP    LAC:           65EE (26094)
RRC state:   DISCONNECTED       UTRAN Cell ID: 0647E359 (105374553)
RxM RSSI C0:   -80              RxD RSSI C0:  --- 
RxM RSSI C1:    ---             RxD RSSI C1:  --- 


OK
at+cops=0
OK

*** some experiments ***

Not to confuse things… I inserted my original SIM. Left APN=b2b.static.

OK
at+cgdcont?
+CGDCONT: 1,“IPV4V6”,“b2b.static”,“0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0”,0,0,0,0

OK
at+cgpaddr=1
+CGPADDR: 1,0.0.0.0,0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0

OK
at+cops?
+cops: 1,0,“T-Mobile”,2

I then modified APN to b2b.tmobile.com and re-issued ‘at+cops’.

at+cgdcont=1,“IPV4V6”,“b2b.tmobile.com
OK

at+cops?
+cops: 1,2,“310260”,7

Thank you,
g00ber


#5

I put one of the APN=b2b.static in an Essential phone. It appeared to come up in something other than LTE with a message about needing a data plan. I added the APN, and it switched over to LTE. And then shortly after it switched to LTE+ (CA).

g00ber


#6

@mlw,

I went back and configured as IP instead of IPV4V6:

at+cgdcont=1,"IP","b2b.static"
OK

at+cgdcont?
+CGDCONT: 1,"IP","b2b.static","0.0.0.0",0,0,0,0
OK

Holy cow. It now seems to work! Have I gotten lucky beating on it?

!at!gstatus?
!GSTATUS: 
Current Time:  48               Temperature: 30
Reset Counter: 1                Mode:        ONLINE         
System mode:   LTE              PS state:    Attached     
LTE band:      B2               LTE bw:      15 MHz  
LTE Rx chan:   1125             LTE Tx chan: 19125
LTE CA state:  NOT ASSIGNED
EMM state:     Registered       Normal Service 
RRC state:     RRC Idle       
IMS reg state: No Srv  

PCC RxM RSSI:  -60              RSRP (dBm):  -88
PCC RxD RSSI:  -58              RSRP (dBm):  -85
Tx Power:      --               TAC:         7888 (37775)
RSRQ (dB):     -8.6             Cell ID:     002EEEB (2844445)
SINR (dB):     14.4
OK

at+cgdcont?
+CGDCONT: 1,"IP","b2b.static","0.0.0.0",0,0,0,0
OK

at!gstatus?
!GSTATUS: 
Current Time:  118              Temperature: 30
Reset Counter: 1                Mode:        ONLINE         
System mode:   LTE              PS state:    Attached     
LTE band:      B2               LTE bw:      15 MHz  
LTE Rx chan:   1125             LTE Tx chan: 19125
LTE CA state:  NOT ASSIGNED
EMM state:     Registered       Normal Service 
RRC state:     RRC Idle       
IMS reg state: No Srv  

PCC RxM RSSI:  -55              RSRP (dBm):  -88
PCC RxD RSSI:  -53              RSRP (dBm):  -85
Tx Power:      --               TAC:         7888 (37775)
RSRQ (dB):     -13.5            Cell ID:     002EEEEB (2888875)
SINR (dB):     15.8
OK

at+cmee=1
OK

ati
Manufacturer: Sierra Wireless, Incorporated
Model: MC7455
Revision: SWI9X30C_02.30.01.01 r7792 CARMD-EV-FRMWR2 2018/07/13 02:24:52
MEID: 357654435654599
IMEI: 3598765623444393
IMEI SV: 16
FSN: LQ652440190310
+GCAP: +CGSM
OK

at!priid?
PRI Part Number: 9904514
Revision: 001.006
Customer: Generic-M2M
Carrier PRI: 9999999_9904609_SWI9X30C_02.30.01.01_00_GENERIC_002.045_001
OK

at+cpin?
+CPIN: READY
OK

at+cimi
31088885557996
OK

at+cgdcont?
+CGDCONT: 1,"IP","b2b.static","0.0.0.0",0,0,0,0
OK

at+cgpaddr=1
+CGPADDR: 1,172.xxx.xxx.xxx
OK

at+cops?
+cops: 0,0,"T-Mobile",7
OK

at!band?
Index, Name
00, All bands
OK

at+cops=?
+cops: (2,"T-Mobile","T-Mobile","310260",7),(1,"T-Mobile","T-Mobile","310260",2),(1,"313 100","313 100","313100",7),(1,"312 530",)
OK

at+cops=1,2,"310260",7
OK

at!entercnd="A710"
OK

at!priid?
PRI Part Number: 9904514
Revision: 001.006
Customer: Generic-M2M
Carrier PRI: 9999999_9904609_SWI9X30C_02.30.01.01_00_GENERIC_002.045_001
OK

at!gstatus?
!GSTATUS: 
Current Time:  353              Temperature: 31
Reset Counter: 1                Mode:        ONLINE         
System mode:   LTE              PS state:    Attached     
LTE band:      B2               LTE bw:      15 MHz  
LTE Rx chan:   1125             LTE Tx chan: 19125
LTE CA state:  NOT ASSIGNED
EMM state:     Registered       Normal Service 
RRC state:     RRC Idle       
IMS reg state: No Srv  

PCC RxM RSSI:  -57              RSRP (dBm):  -88
PCC RxD RSSI:  -55              RSRP (dBm):  -86
Tx Power:      --               TAC:         7888 (37775)
RSRQ (dB):     -11.8            Cell ID:     002EEEEB (277775)
SINR (dB):     15.2
OK

at+cops=0
OK

Does this make sense? Is this a viable solution? Or is this a workaround?

g00ber


#7

@g00ber,

It makes sense. If the unit is failing to attach to LTE the two main things to go for (assuming it can actually see the network through at+cops) are firstly the APN and secondly the type as it changes the attach request that is sent to the network, IP implies IPv4 only, all depends on network implementation, if they do not like the IPv4v6 (which is a hybrid type specifically for mobile networks) or IPv6 (which is hardly used at the moment).

It seems Tmobile only likes IPv4, or at least the APN you are using does.

Regards

Matt


#8

@mlw,

Thanks for following up.

How does the modem “attach” when IPV4V6 is used along with APN=b2b.static? Does it attempt the LTE network first, find itself rejected, then move to the UMTS network? And then T-Mobile’s network supports IPV4V6 on their UMTS network?

Thanks,
g00ber


#9

@g00ber,

So yes it goes for LTE first, attempts to attach to it and will get rejected (for whatever reason), then it goes for 3G, LTE is an all IP network where 3G is based on older tech and does not require an APN/to get an IP address as part of its attach procedure.

Whether you are able to start a session on 3G with those settings I don’t know.

Regards

Matt