MC7710 & QMI Drivers

Hi there,
from some days I’m trying to use the QMI drivers with the MC7710 modem. Unfortunately as i can see, the product code of this modem (1199:68A3) is not listed.

Is it supported? I’ve also tried to force the module to take care of the usb device but even if it creates the ttyUSB devices, it doesn’t create any /dev/qcqmi% device.

I’m using the latest version of the QMI drivers (SierraLinuxQMIdriversS2.8N2.13).

Any suggestion?


I am afraid the MC7710 you ordered is not configured in QMI mode.

To change it to QMI mode, please use below:

AT!ENTERCND=“OEM password”

On return, it should be in QMI mode.
Kindly refer to AT command guide for command usage.
For the OEM password, please check with the distributor.

Hope it helps.

Done, now work perfectly! :smiley:

Thank u so much!


I use MC7710 in QMI mode and I will switch to DIP.
Is it the same way?

AT!ENTERCND=“OEM password”

many thanks for help, microBit

Yes, it is.

Hello Iotam,

Please I think that I may be facing similar issue. Just that in my case I think that the MODEM is in DIP mode. In windows adapter setting.My it see’s the card as ETHERNET adapter and I have tried several times to reset the modem to factory setting or update the firmware to QMI so that widows may recognise the card as cellular card.

Please how do I know the OEM password of the card? So that I can try same command you shown Salvatorenoveli. Also I will like to know if I should use 68A2 for AT!UDPID? For now I am only able to connect to the internet via AirCard Watecher


Please how do I know the OEM password of the card? And what is the difference between using the the modem in DIP or QMI firmware mode?

The password has become public knowledge since the original posts in this thread. See for example Is there any timeout for password protected mode (AT!ENTERCND="A710")?