MC7455 GPS Setup


I’ve been trying to obtain GPS data from the MC7455 modem, however I’ve run into some trouble. When I try to track using the Skylight application (build 4442) it just gets stuck on acquiring location. I also see data being posted on the NMEA port, however when I try to parse it with one of the online NMEA parsers it turns out that it doesn’t really contain any information.

So I decided to try and see if I can get it fix using some of the AT commands. I’ve set
as well as
However there’s still no difference. If I try !GPSTRACK or !GPSFIX I just receive an ERROR.

I also tested the antenna that I’m currently using with another modem and it worked fine.

Any ideas?

Hello, Skylight is not really being supported as windows MBIM CM is now what is being used.

Please try this from an AT terminal session:

  1. AT!GPSAUTOSTART=1,1,255,100, 1
  2. Make sure you have enabled the AT+WANT=1 for an active antenna
  3. You antenna has a clear view for the sky
  5. Type AT!GPSSATINFO? several times to start showing the satellite fixes

See if this works over using Skylight.


Hi Jon,

I tried what you’ve suggested, however to no avail. I don’t really mind if skylight isn’t working, what’s important is to receive the correct information on the NMEA port. I’m also attaching a screenshot if that’s helpful.

Actually after I restarted the PC it finally worked.

Yes, I see it now worked and you usually need three or more satellites to be in view to get the accurate positioning and NMEA strings. Jon