[MC7354] Skylight unable to Read or Send SMS messages

So i recently updated my USB Drivers for my MC7354 using the new 4431 Build but i think its causing issues with the current release of the skylight program.

Specifically, i’ve lost the ability to read and send SMS text messages from the application.

If i have my device in USBCOMP mode 6 which has the QMI interface, Skylight will display the usual information, except the button to open the SMS mailbox window has disappeared! "-_- Subsequent investigation through the application menu also shows it has no options for SMS anymore, and the section in the settings for SMS has disappeared as well.

I tried switching the device to USBCOMP 8 to see if the MBIM interface would work instead (As i use it on a Windows 10 laptop), however in doing so, Skylight shows no information except for a tiny little message that says, “Modem Detected”…sigh, and most options in the menu are greyed out.
On an interesting note though, when the device has the MBIM interface exposed, the Messaging application (The new app provided by microsoft in Windows 10 for messaging through Skype and SMS) pops up with any SMS messages i may have received and displays it in the application itself. I tried sending a message through it to see if it would work, but all i get is an error that says it can’t detect the SIM card or the device is in Airplane Mode (Which its not, i double checked, that and Skylight never had an issue sending or receiving SMS messages with either MBIM or QMI up until recently)

Now all of this is using the Generic Firmware so far, but here’s were things get really interesting:

If i switch the device to firmware, i get the full functionality of the application back again. I still get the same SIM card error if i use the Microsoft Messaging App, but i’m able to send and read SMS messages through skylight normally.

Anyone have any ideas as to why Skylight is doing this all of a sudden?
The only thing i did differently when installing the updated drivers was extract the win10complete.xml file from the driver package, then ran the installation through command line with:

GenericDriverSetup_4431.exe -xml=Win10Complete.xml

Beyond that, i have not changed any settings on either the modem or the OS since installation.

i know this is an old topic but I am facing the same issue right now.

need help!