LX60 can't enable wifi or upgrade firmware


I’m the commo for a rural VFD. We have an LX60 in our command vehicle that had been working fine to provide a mobile wifi hotspot and wired internet using a Google Fi data-only SIM. A couple months ago the wifi SSID disappeeared, so I logged into the device GUI to check it out.

I found wifi disabled, but when I re-enable it (with all the same settings as before), apply, and reboot it just comes back disabled again. The Aleos firmware is 4.10 so I tried to update it but keep getting failure message about being unable to open the fwinstaller. The log shows a checksum error. When I try to update the radio module firmware, the process completes and the device reboots, but the version remains the same (2.10 I believe - I’m not in front of the device right now).

I thought that it my be a problem jumping directly to the latest releases, so was able to locate older firmware on the Sierra Wireless site, but got the same result with 4.13 and 4.14. I couldn’t try anything else as the links appear to be dead.

I’m new to this product line, but very experienced with all things networking and telecom related. I’d be very grateful for any advice or suggestions, as we really need to get this working and don’t really have the budget to replace it right now.


Hi @don
Welcome you to our community!
According to your description, Your LX60 still working fine a couple months ago. So,

  1. Please try restore to factory the modem then try again, Do the issue still happen in this case?
  2. How did you update the ALEOS firmware ? Can you describe step by step? Please share with me the screenshot of the issue.