LX40 issues with ATT activations

My lab purchased 16 LX40 units. I initially activated 2 with Verizon, and eventually activated 8 total with Verizon and 8 with ATT. All the devices were shipped with:
ALEOS 4.13.0
Radio SWI9X07Y_02.28.03.01 000000 jenkins 2019/04/17 03:08:11

With the first 2 Verizon units I found that I often couldn’t remote connect to them. A power cycle or a direct login would clear that issue. I updated them to:

ALEOS 4.15.1
Radio SWI9X07Y_02.37.06.00 b91e64 jenkins 2020/06/02 00:54:15

The issue was resolved after the update. I then proceeded to update each unit with 4.15.1 and either the Verizon or ATT Radio Module. The Verizon units have been fine, but I’m having about a 50% problem rate with the ATT activated devices. For example, I send what I believe to be a functioning ATT device out, and when it is tried by a colleague it won’t connect.

Under Status->Cellular->General
there are no lines beginning with LTE. It’s as if the device believes it is only a 3g device. One just came back to me and I’m playing with it now. I haven’t done anything more than powering it up. Thought I’d post here before taking a next step.

Hi Gary.Hodges,

I just want to make something clear. Do you face an issue that some LX40 gateways stay in 3G and cannot connect to 4G?

Sorry if I get something wrong


Thank you for the response. That is how it appears to me, but I’m certainly not an expert when it comes to these devices. I have one device in my office that has no LTE signal strength information lines showing. Another I expect to show up today has the same issue. I have configured all 8 ATT activated devices exactly the same.

FWIW at the two locations this occurred, Sterling, Virginia and Salt Lake City, 3g ATT service was still active. So even though the devices seemed to be 3g only, neither would establish a connection. I’m also 100% certain it was not a cellular coverage issue.

I just uploaded screen shots of the login screen and the status screen. LTE is shown on the login screen, but not the status screen. With my Verizon activated modems I have seen RSRP -140, RSRQ -20, and SINR 0 during the initial power-up of a couple devices I sent out, but I’ve always been able to login. I then issue a software REBOOT and it comes up as expected.

The issue seems to be resolved. I read the other LX40 4g/3g thread and tried swapping SIM cards around. I also sent an email in to my account contact with ATT to verify the SIM was active. ATT came back and said I had deactivated the device with the phone number associated with that SIM. OK, maybe I copied-n-pasted incorrectly. In the final analysis, unless I’ve completely mistyped or overlooked something, it appears I simultaneously had two active modems with the same assigned phone number. Is that even possible? It seems so. ATT reactivated the phone number, assigned it to the 4g hardware, and the LX40 is now working fine.

I guess it doesn’t completely explain the 2nd and 3rd devices that have done something very similar. I’m waiting to get one of those back. The other I was able to get going through FDRs. I checked my spreadsheet for more duplicate phone numbers and I don’t see any others.

EDIT: I located a second shared/duplicate number between two devices. I just received confirmation from the colleague I sent the 4g device to that it is not working. Just sent another email to ATT.

EDIT: Round 2 with the other modem… ATT removed the number from the 3g device and attached it my 4g device. It then worked fine. I guess ATT must have “upgraded” a couple lines rather than give me all new activations. What a hassle.