LX40 Does Not Connect to 4G only 3G

Hi, I have a LX40 that use for backup Internet for about 2 years and it has not been able to connect to 4G, only 3G. I have 2 beam antennae pointed to the strongest signal and I have taken it mobile and it will only connect to 3G. I had updated the firmware etc. I use it for a backup Internet for my work laptop so 3G has been fine that couple of times my ISP went out so I have not been worried about it. Now the 3G is being shutdown I’m not sure what will happen (I just tried now and it only connects to 3G) when it goes off soon, supposed to have been Monday. I have ATT in the states. I called ATT and they say it should work but since it was not bought from them your are on your own basically. I called Sierra wireless and they said it should work on 4G. I’m not sure if it is the SIM card that ATT gave me? I was curious if someone else has had the same problem.


Hi thorn,

First off, could you please double-check if your sim worked properly with 4G? You could check your sim with another device such as your phone.

Where did you get the latest firmware? I just want to confirm if you got the correct one. The official FWs are located here:

In case there is no problem with the 2 things above. Please share your configuration file so I could take a look at it. The configuration file is in ACEmanager → Template, click Download button.


Hi, I’ll try the SIM card in my phone tonight. I think I have to call ATT and give them the MAC address or something like that for it to work, I’ll try it first to see what it does.

My SIM cards on my other devices are all smaller and I don’t have any adapters and the large one from the LX40 is too big. I may have ATT drop the device and I’ll ask for a new SIM.

I updated the firmware.

I finally got to the ATT store and they gave me a new SIM which worked!