how to send AT COmmand directly using application


#1

Hi all,

just like the thread’s title, I want to send an AT Command directly to my modem using the application.
i’m using VC 6.0 as the IDE. i know that there is a command adl_atCmdCreate (“the AT COmmand”, TRUE/FALSE, CallBackHandler, “events”,NULL);
i have used this command to send sms from my application. and is worked perfectly previously. but after i reinstall my firmware ,because i got my modem into an infinite loop, the adl_atCmdCreate is not working anymore. seems like any AT COmmand that i wrote is ignored by the modem.
here is the step that i did.

i want to send AT+CGATT = 1 to my modem using my application.
i wrote adl_atCmdCreate (“AT+CGATT = 1”, TRUE, (adl_atRspHandler_t)gprsAttachHandler, “*”,NULL);
i made the gprsAttachHandler function to send an unsolicited response “attachment successful” to my Hyper Terminal.
i downloaded the program using AT+WDWL
i ran the program.
and the program send a response “attachment successful” to my hyper terminal.
but when i check the AT+CGATT value, the value is still 0.

could someone give me a light about what happened?

FYI: the firmware on my modem before i had the infinite loop is v4.30, and after i reinstall the firmware it became v6.00


#2

Those are significantly different versions!

It is very likely that an Application written for firmware v4.30 would not be compatible with v6.00!! :open_mouth:

At the very least, you would need to rebuild the application; most likely, you would also need to make other changes to your source code to match the API changes…


#3

sorry it was my mistake. what was changed was my Open AT OS. from 3.14 into 6.01. but the firmware is still the same. v7.1.
i read and compare it from my Open AT Project Wizard, between my Open AT (v2.0) and my friend’s Open AT (V3.14).
from the Open AT Project Wizard window we can see that which Open AT OS we’re using.

but the Firmware on my Fastrack Supreme 20 (Q2686) is 7.1. and it’s compatible with Open AT OS version 6.01. (i read it from the RN_Open_AT_Firmware_R7.1_Preliminary_Release_Note-002.pdf). so i think there is nothing wrong with my system. and my application program was created with the same system, only the difference is the Firmware was reinstalled.

FYI : i use DWL win and Firmware file R71-CUS-q26_03.wpk to reinstall my Fastrack Supreme 20

thank you for you time and explanation.


#4

I have a problem - adl_atCmdCreate isn’t working.
For example:
if (adl_atCmdCreate(“AT+WMFM=0,1,2”, NULL, NULL, NULL )) adl_atSendResponsePort ( ADL_AT_RSP, APP_ATCMD_UART, “\r\nGPS UART2 OPENED\r\n”);
else adl_atSendResponsePort ( ADL_AT_RSP, APP_ATCMD_UART, “\r\n CAN’T OPEN GPS UART2\r\n”);
The answer is always “CAN’T OPEN GPS UART2”.
Even when i send adl_atCmdCreate(“ATI”, FALSE, NULL, NULL ) or adl_atCmdCreate(“ATI”, NULL, NULL, NULL ) there is no any response from modem. It’s looks like the modem just ignore that function…
Same problem with any AT commands I want to send.
Version of OpneAT is 4.25.
OS is 663c00_full_q2686h_W11.