How to get PLMN information with adl_L3infoSubscribe() API


#1

I use adl_L3infoSubscribe() API to subscribe a ADL_L3INFO_CELL or ADL_L3INFO_SCAN handler, but it return -13, which means my WCPU can not support the function,

my WCPU: Q2687G
firmware version:  R71_00gg.Q2687G
OS version: 06.02

for This WCPU, it should support that function, does any body can help me, or give me some advice? how can I get the PLMN and RSSI info in WCPU?
Thanks for any help.


#2

Hiya,

Please don’t cross-post the same entry to multiple forums. It just annoys people :confused:

Have you checked the result of AT+WCFM=5 - the Layer 3 functionality is an extra commercial feature that has to be enabled by Wavecom.

See the AT Command Interface Guide, section 6.5 (this is for firmware R7.4 - other versions may be different) for info on decoding the output of the AT+WCFM command.

If the Layer 3 functionality is not enabled, you will have to contact your distributor to pay for the updates to your modem.

ciao, Dave


#3

I think the ADL User Guide should clearly state where functions rely upon “commercial features” like this.

And I think this is another on for the FAQ?


#4

What “PLMN Info”, exactly, do you require?

Have you looked at AT+CCED :question:

Signal strength can be obtained with AT+CSQ


#5

Hiya,

Please don’t cross-post the same entry to multiple forums. It just annoys people

sorry!I dont know which forums it is more suitable to submit the questions to,
I will delete anyother


#6

by awneil » Tue Sep 15, 2009 6:55 am

What “PLMN Info”, exactly, do you require?

Have you looked at AT+CCED

Signal strength can be obtained with AT+CSQ

yes, we can get some PLMN info by AT command,
I want to get the MCC,MNC and RSSI, My question is how to get those info inside WCPU via APIs directly, not send AT command to WCPU and WCPU reponse the result.
I want to get and indicate those info by WCPU, like PLMN_Scan example do.
Do you have any ideal how to send AT command inside WCPU and get response by itself?
Thanks for any help!


#7

I check my WCPU with “+WCFM” command

at+wcfm=5
+WCFM: 00000471,0
OK
at+wcfm=2
+WCFM: 0166,0

the AT user guide (firmware R71) decode explain as following, as if my WCPU can not support the PLMN scan function.

: requested operation
0 disable some features of
1 enable some features of
2 display the features state
3 disable some extended commercial features of
4 enable some extended commercial features of
5 display the extended commercial features state
: features mask
16 bits hexadecimal string
commercial features ( =0, =1 or
=2) :
02 GPRS Class 2
04 Wireless CPU® Highest GPRS CLASS allowed
10 Open AT® Bluetooth Plug In
20 Echo Cancellation Algorithm
40 EDGE (EGPRS)
80 Wavecom debug feature
200 DOTA 3
400 IDS Third Server

extended commercial features ( =3, =4 or
=5) :
01 Internet Plug In
02 MQTT: IBM Websphere
04 ORANGE M2M Connect
08 Open AT® GTI Plug In
10 Real Time Operating System
20 Open Sim Access
40 Open AT® C-GPS Plug In
400 Watchdog


#8

Yes - read the section in the ADL User Guide about AT Commands!

Please note the ‘QUOTE’ button that appears in the top-left of each and every post on the forums - if you want to quote a previous thread, just press the ‘QUOTE’ button, and it will start a reply with that message quoted.
Edit that quote as required to leave only the relevant portion…


#9

Yes - read the section in the ADL User Guide about AT Commands!

Thanks! I will try it.


#10

and don’t forget to use the ‘Preview’ before you press ‘Submit’ - to check that you have your formatting correct!


#11

Hiya,

I’m running firmware R7.4.

In the AT command guide, on the top of page 87, the table you previously posted continues:

200    Raw Spectrum Info used by the L3Info open AT service   
400    Watchdog   
800    "Reserved for future use" (Open AT Airbiquity plug-in is not sold)

I’ve had a quick look back through older AT guides, and the option 200 for AT+WCFM=5 only appeared in R7.3.

You’re running old firmware. Try upgrading your modem to R7.4 (and Open AT to Oasis 2.30) and see how you get on.

ciao, Dave