How to change carrier (e.g. DOCOMO => SOFTBANK) with out rebooting WP76xx?

We are using wp7605 and we know that there are dedicated firmware for each carrier such as DOCOMO.
Is it possible to change carrier (e.g. DOCOMO => SOFTBANK) without rebooting wp7605?
We want to support multi carriers on one firmware.
Thanks in advance for your advice.

you can see the document here:

In page 10, it says that if you use AUTO-SIM feature, it needs to reboot to switch FW.

Thank you for the infomation.
I have two questions.

  1. Is it correct that WP7605 does not support the image switching mode explained in “4118344_Image Switching M2M Developers Guide_r2.pdf”?

  2. “4115290_Firmware_Image_Switching_Developers_Guide_r2.pdf” explains the switching method using APIs. Are there any documents that explain the low level code samples that execute the Image switching?
    We are using RTOS and we need to develop the software for ourselves.
    Source code of the corresponding API would be a good help for us.


  1. I think WP76 module supports image switching.
    This document already include WPX5 modules.

  2. I think you should try AT command first.

Thank you for the prompt response.
I checked the document "4118344_Image Switching M2M Developers Guide_r2.pdf” and found that “Table 1-1: AirPrime Modules Supporting Image Switchinga” does not include wp76xx. So, I guess that wp7605 does not support “on module image switching”.
We hope the module changes the image automatically when the external circuit change SIM.
We will check AT command also.

i think the document is not updated, you can try with AT command first.

It’s a good news that WP7605 supports on module switching function!
I’ll check using AT command.
Could you tell me how to send AT commands from the development environment?
I’m using VSCode with Legato plugin on ubuntu.
Sorry for my primitive question.

you can use minicom to open /dev/ttyUSB2 port to send AT command.

Thank you for the advice.
Following is the response from the Modem.

FW 1 FOTA 1 0 0 001.024_000
FW 2 EMPTY 0 0 0
FW 3 EMPTY 0 0 0
Max FW images: 3
Active FW image is at slot 1

PRI FF GOOD 0 0 0 001.024_000
PRI FF GOOD 0 0 0 001.026_000
PRI FF GOOD 0 0 0 001.032_000
PRI FF GOOD 0 0 0 001.028_000
Max PRI images: 50

I understand that WP7605 has three firmware slots.
So, I’ve tried to send another file to the second slot using “fwupdate” command but not successful.
I’ve entered at the target console as follows,

root@swi-mdm9x28-wp:~# fwupdate downloadOnly ./WP76xx_Release13.3_KDDI.spk

but the response is ,
Can’t open file ‘./WP76xx_Release13.3_KDDI.spk’ : No such file or directory

I think I’ve misunderstood something.
Are there some method to send the second modem file to the second slot of WP7605?
Thanks in advance for your suggestion.

Did you transfer the spk file to module by scp?

Yes, following is the command to the console of ubuntu,

ffdtest2@temaeda-All-Series:~$ scp ./WP76xx_Release13.3_SOFTBANK.spk root@

and the following is the result at the target device,

root@swi-mdm9x28-wp:~# ls

May be the location of the files is the problem?

root@swi-mdm9x28-wp:~# pwd


I’m afraid I’ve done some mistake.
Legato framework in Target device seems to stop running.
Target doesn’t accept any Legato commands such as ‘cm info’.
Following is the result,

root@swi-mdm9x28-wp:~# cm info all

When I try to install application, following is the result,

Executing task in folder workspace: update /home/ffdtest2/workspace/TEST11.wp76xx.update <

Applying update from file ‘/home/ffdtest2/workspace/TEST11.wp76xx.update’ to device at address ‘’.
Update failed
Systems installed:
25 [good] ← current
Legato framework is NOT running.
The terminal process “update ‘/home/ffdtest2/workspace/TEST11.wp76xx.update’” terminated with exit code: 1.

‘Legato start’ command does not work.

How I can start Legato in the device?


You should upgrade the fw in windows exe

I’ve tried “WP76xx_Release13.3_DOCOMO.exe”.
Although the software seems to have finished normally, the situation is the same.
Legato framework in Target seems not started and when I entered e.g. “cm info”, just the prompt returned as follows.

root@swi-mdm9x28-wp:~# cm info

I’ve tried “swiflash” as well, but the result is the same.

Are there any other method to recover the system to the shipment state?


you can downgrade to R12 and then use swiflash recovery mode.

Thank you for the advice.
I’ve done “swiflash” WP76xx_Release12_ATT.spk first, then “WP76xx_Release13.3_DOCOMO.spk”.
But the situation is the same.
I’ve found one thing.
When I check the status of Legato, the response is as follows.

root@swi-mdm9x28-wp:~# legato status
Systems installed:
25 [good] ← currentcat: can’t open ‘/legato/systems/needs_ldconfig-/index’: Not a directory

[untried] ← ERROR: index file doesn’t match dir name.
Legato framework is NOT running.

I guess that Legato does not start because of this kind of error.

Are there any hints in this response?


did you do “swiflash -m wp76xx -r” when you were in R12?

Thank you very much for the advice.
I’ve done “swiflash -m wp76xx -r” before the swiflash of R13.3 and the system seems to be the initial state.
The system works fine and we can restart the development.

I guess the system went bad when I had tried to send the second spk file to the second slot using “fwupdate” command.

root@swi-mdm9x28-wp:~# fwupdate downloadOnly ./WP76xx_Release13.3_KDDI.spk

Is this procedure wrong?
I’d appreciate your suggestion regarding sending the second spk file to fill the second slot of wp7605.

I only use this

fwupdate download ./tmp/WP76xx_Release13.3_KDDI.spk

Let me confirm about your “fwupdate download ./tmp/WP76xx_Release13.3_KDDI.spk”.

  1. Do you enter the command at the device console (such as root@ ?
  2. The spk file is in home/root/tmp of the Target device?

I’ve tried the same thing but the result is,
root@swi-mdm9x28-wp:~# fwupdate download ./WP76xx_Release13.3_KDDI.spk
Connecting to service …
Can’t open file ‘./WP76xx_Release13.3_KDDI.spk’ : No such file or directory
root@swi-mdm9x28-wp:~# ls
WP76xx_Release13.3_KDDI.spk WP76xx_Release13.3_SOFTBANK.spk

I don’t understand the cause of the error.