HL8548 UART communication


#1

Hi guys
We are doing a phone, which using a HL8548 (without “G”) module
I have bought HL8548 module from a lot or supplier. But this time, I have tried with a Chinese supplier
Now I have on hand 110pcs module with nice looking(there is no FCC ID on the marking, pls check below link for the module looking https://photos.app.goo.gl/m1twAL34taDPkwBRA ) but not working well
They can be turned on ( I check the V_GPIO=1V8 after power up), but there is no way to communicate with the modules
It doesn’t send out any thing via UART pins (5 and 6 pin).
Normally there will be
" +SIM: 1
+KSUP: 0
…"
But with these module ( I have tested one), it doesn’t sent out any thing. And when I send AT /r/n, there isn’t any “OK”
I am thinking of upgrading firmware for those modules.
Can you guys show me how to do this, or anything to make these module talk to me via UART

Thanks for reading
Ryder

P/s: I have changed the baudrate form 9600 to 115200, but it didn’t work


#2

hi all
good news
I have talked to the HL via uart successfully
I have connected CTS and RTS pin together and is just worked!
But I have read out that it’s firmware is to old (5.5.3)
Could you guys tell me how to do the firmware update for this module?

Thanks
Ryder


#3

Maybe the flow control setting different, can you check and share the return of:

AT+IFC?
AT&V

Thx


#4

Hi Ryder,

V5.5.3 is too old to support the upgrade the FW.dwl via Xmodem AT command(+WDSD).

Please go to Sierra’s website to download the FW(*.exe File) :
https://source.sierrawireless.com/resources/airprime/software/hl8548-hl8548-g-hl8549-and-hl8549-g-firmware/

Install driver FlashUSB_Driver_1_0_1_1, then you can double click FW.exe to upgrade via USB cable, a module reset is needed during the upgrade.

If you have only the UART interface, no USB interface, you just need to create a new ini file named “HL85xx_download.ini” in C:\Users\xxx\AppData\Roaming( or see your system environment %APPDATA%), when the .ini is ready, double click the FW.exe.

Content in the HL85xx_download.ini should be like:
[CommPort]
Port=COM1
ComBaud=115200


#5

hi friend!
Thanks for your support
I have updated the firmware successfully

Thanks alot
Ryder


#6

hi friend
thanks for you reply!
i will check latter and confirm to you
now i am doing the firmware update

Thanks
Ryder