Migrating from HL8548 to HL7650/7688/7800

Hi guys, am having some issues replacing the HL8548 with any of the above options. As far as I know, they are drop in replacements, so have loaded one of each on my existing dev board, where the HL8548 was working great. But I don’t seem to be able to establish coms over UART1 with any of them, I get nothing back. The 1V8 output looks OK - I can see it coming up when the PWRON pulse is sent, but after this, no response. Any ideas about why this might be or what I might be missing?

Many thanks,
Dave

Hi DKV,

Please check if sleep mode enabled for HL7650/HL7688/HL7800.
If module enters sleep mode(CTS is inactive), then no reponse of AT command. In this case, try to toggle DTR or RTS to wake it up.

Suggest check first in HL dev-kit with UART and USB port.

Thanks for the reply. It looks like the HL7800 issue was a loading issue, this is working fine now. The 7650 and 7688 are still not giving me any joy. Would it be possible that they are configured to one of the sleep modes described in the tech spec? I’ve tried toggling DTR and RTS but still no activity on the UART lines. Would you expect to be able to plu and play or is it quite possible the modules are in some idle state?
Many thanks,
Dave

Hi Dave,

Do you test HL7650/HL7688 in you own unit in 2-wire UART? 4-wire UART? or 8 wire UART?
How about the USB interface? Do you see some USB interface enumerated?
and do you try with HL dev-kit?

Thanks, yes I am testing on my own board in 4-wire uart. I have also tried 2 wire as per the technical spec. The most interesting thing is that on power-up I don’t see the unsolicited data coming from the modem. On the other units, as soon as the modem is powered it sends a few config packets on the UART port but I see no activity at all on the UART on the HL76XX modems on start-up. That’s what makes me wonder about a sleep mode.

I also notice that on the other units, CTS is low after power-up, but on these HL76XX, CTS is high. I have tried toggling RTS and DTR but have not seen any activity on the UART. I have also tried sending the at command 0x00 as per the technical spec but still no activity.

I havent tried the USB interface yet, I will try that. I don’t have access to the dev kit right now so have not tried that.

Could you confirm that you would not expect any difference with the HL7650 and HL7688 as far as start up and coms is concerned? I should be able to switch from HL8548 without any changes to uart or startup settings right? Please let me know if you have any other ideas…

Many thanks,

Dave

CTS keeps high may means module is not started up or modem is in sleep.
Could you check VGPIO?

Yes, normally we can see some URC during start up, but it depends some AT command settings. e.g. +KSREP, +KSIMDET, +CREG etc.

If you use 4-wire UART (rx, tx), toggle DTR could wake up modules.
If you use 2-wire UART (rx,tx,cts, rts), try to set modem RTS pull down to GND, then send any character could wake up modem.

In my HL dev-kit(SKU 1400897 Rev-1), when I mount the HL8548, HL7650, HL7688 and H7800 modules, they all work fine.

In your unit, could you check how module GPIO is connected? pull low? pull high?
Still suggest try with dev-kit first.