HL8548 firmware update

Hi guys
Pls help me to update the firmware of the HL8548 module
I have tried to update via USB port, but it didnt work
Is there any way to update via UART port of the module?

Thanks for reading

Hi Ryder,

To update the HL8548 you need to download the latest binary from the Source website.


For each version you have 2 options. You can either use the Windows OneClickTool (exe) or the X-Modem version (.dwl).

1. OneClickTool - USB

Simply connect the HL8548 USB to your windows computer and run exe.

AS a pre-requisite you need to install the USB drivers:


2. OneClickTool - UART

similar to upgrade over USB but you need first to Configure the OneClickTool for UART download since by default it relies on USB.

To use the one-click tool to download over UART, you are required to create a HL85xx_download.ini file.
The .ini file specifies the COM port and baudrate
The file ‘HL85xx_download.ini’ must be placed in the folder path specified by %APPDATA%

The following example shows to use COM port 15 and set the baud rate to 460800 bps.
Even if your are using 115200 for AT command, you can set a higher speed for the download. 460800 is recommanded

File content:


In case you are not familiar with %APPDATA% , this is a Windows environment variable.
To find it, just type %APPDATA% in the Start menu search section.
by default on Windows7 it’s the following folder:

3. X-Modem downlaod

You can use AT+WDSD command to load the binary in the module.

For the size you need to enter the exact size in Bytes of the xxx.dwl file. Accessible under widows with a right click in the File Explorer

Once you receive the NACK characters send the binary using 1k X-Modem protocol. A tool such as TeraTerm can be used for this task

At the end of the download you will receive a +WDSI: 3 indication

Send AT+WDSR=4 to launch the installation.

Wait for the module to restart.

You can refer to the AT command guide for more details:

hi BBo
i have followed to your 2nd suggestion and it is running well now

thanks for your support


Sorry by reopen this topic.

Well, I have a Mangoh red board and I want to update the firmware.

After the help of @jyijyi , my Win7 machine identified the modem. My problem now is how to update the firmware. Currently my machine is identifying six USB ports into the Mangoh connection:

I tried to use the OnClick tool, changing the COM ports, but it is not working.

Can someone help me?

can you do AT command communication on these ports?

I tried with all ports. The unique that returns something is the COM24:

ùöyÞ ÉN

I think that it doesn’t make any sense…

seems your module is not working as AT command is not responding…

maybe yes. I changed the module by another one. With this new module, I can access the AT commands.

Considering that the previous module is dead, what I can do?

No idea, better use the working one

1 Like



if there is no solution, it is solved.