Dev kit HL8548-G firmware

I’m trying to install the latest firmware on the HL8548-G on the development kit but I’m not getting anywhere.

How can this be done?
Regardless of the connection on the dev kit the firmware updater doesn’t see a reset of the kit.

Hi,
How are you trying to update FW? via USB or UART?
If you remove the power to dev kit and apply that again - is it helping?
Are you getting any warning in your command prompt? Is it possible to share the screenshot of the same?

Thanks,
Alex

I’ve tried both UART ports and both USB ports on the dev kit.
On the UART1 port I can communicate via a USB serial converter over COM9.
On the USB1 port I can see communication over COM3 (which according to the OS is USB1 on the PC).

On every port the reboot of the dev kit isn’t detected.

Regardless of the ports used I get exactly the same response.

Screen dump:

Log file is “C:\Users\CASVAN~1\AppData\Local\Temp\HL8FW_r3293.log”
Use Port: USB1

Intel Command Line FlashTool v.1.37 (Download Library v.4.140,0.0 )

psi.fls (PSI) (NAND)
slb.fls (SLB) (NAND)
AENEAS_FW.fls (Code) (NAND)
SAM_6260.fls (Code) (NAND)
SAM_6260-MSY.fls (Code) (NAND)
SAM_6260-CDS.fls (Code) (NAND)
Booting ‘C:\Users\CASVAN~1\AppData\Local\Temp\7zS8C47.tmp\temp\psi.fls’, memclass: PSI
-> Please reboot your phone device <-

Process time was 1 min 0 sec.

Library Error: IMCDownload.cpp:508 - USB Boot Timeout (1)

Please refer to the log file “C:\Users\CASVAN~1\AppData\Local\Temp\HL8FW_r3293.log”
Press any key to continue . . .

The log file doesn’t contain any additional information.

Using Windows 7 Enterprise - Service pack 1 on an Apple IMac.

I can’t use Firmware Over The Air as the current firmware will not connect to any APN. This is just one of the problems I hope to fix with a new version of firmware. Current firmware version: BHL85XX.5.5.4.0.201409051956.x6250_1

Thanks,
Jon Beute

Hi,
can you try my second point? removing the power of dev kit and apply that again?

Thanks,
Alex

I’m actually doing that every time. It does seem to best way way to ensure a reboot.

it seems so…

Thanks,
Alex

Hi,

The update needs to be done through the port labelled USB1_MAIN on the dev kit. If you plug it in normally does it enumerate lots of ports? Do you have a screen shot of the properties of the device?

I can’t remember if the firmware that old was functional with USB (downloading is). It sounds to me like you don’t have the right drivers for performing a download on your system. You will have to get hold of them through your distributor or SWI FAE.

Regards

Matt

Screen dump of the devices added for the dev kit:


Property of USB1:


The device driver for the dev kit has installed properly and communication can be established only the firmware can’t be updated. It appears we have several chips here that don’t work and can’t be updated.
We have already ordered some new chips and hope they come with a more recent version of firmware. We’ll talk to the Sierra sales staff about our existing chips.

Thanks,
Jon Beute

Hello!,

I had the same problem, mentioned in another thread:

Upgrade over USB didn’t work I got timeouts every try, or driver didn’t get correctly loaded on every reset. So you can do the upgrade also over the serial port. But there is no documentation and the flasher uses always USB1, so the trick is to put the attached .ini file in the %APPDATA% folder (just enter %APPDATA% in the explorer).
In the .ini file you can specify another uart and baudrate:

[CommPort]
Port=COM1
ComBaud=115200

Then start the upgrader and enjoy :slight_smile:

But finally I’m really disappointed from the documentation of such things :imp:
HL85xx_download.ini (37 Bytes)

This actually worked.

Thanks for the mail.

This information should have been provided by Sierra on their download site.

One detail

It is necessary that modem is configured in 115200 baudrate. if it is in other baudrate even configuration file has the same baudrate it won’t work.