HL7810 firmware upgrade fails on Linux

This post is similar to this one: HL7812 firmware upgrade fails immediately on linux - #2 by jerdung However, there wasn’t a resolution for that post, so I’m creating a new one.

I’m running the one-click firmware upgrade package for Linux on an Armv7 processor without a dev-kit, but it’s failing immediately. The interface being used, ttyACM1, is a USB interface. The baud rate 115200 should be correct because I’m able to use that interface to send and receive AT commands. I’ve tried to follow the firmware upgrade instructions for Linux as closely as possible.

Command output:

# ./launch.sh

HL7810. - Firmware Download

Console Log file's location: "/tmp/HL7810."

Download Log file's location: "/tmp/HL7810."

Reading INI file /root/HL78xx_download.ini...

Use Port: ttyACM1

Use Baud: 115200

Use HwFlow: 0


************ Download Start (Fri May 5 23:18:22 UTC 2023) ****************


./ImageBurnTool -f "/tmp/HL7810." -v "${PWD}/RK_03_02_00" E0_SB -n 1 -s 1 /0 /1 /11 /18 /2 /4 CATM /7 /12 /19 /3 /10 oneSKU_config "${PWD}/RK_03_02_00/Images/mcu_disable_ALT1250_E0_SB.bin" /16 "${PWD}/RK_03_02_00/Images/AISE_blob.bin" -uartparams 0 2001 115200 0


************ Download Failed (Fri May 5 23:18:22 UTC 2023) ***************


Please refer to the log files /tmp/HL7810.*.log

Press enter to quit...^C

The log file “/tmp/HL7810.” does exist, but it only contains an exact duplicate of the above output. The other log file mentioned in that output, “/tmp/HL7810.”, does not exist at all.

What else I’ve tried:

  • Using UART instead of USB
  • Running this on an x86-64 Linux machine
  • Using the other USB interfaces to the modem, ttyACM0 and ttyACM
  • Using the dev-kit with my x86-64 Linux machine
  • Running the one-click package for Windows. The modem wasn’t connected when I ran it since I didn’t have my devk-kit with me at the time, but the output of the command was still very different despite failing; it waited ten seconds for the modem to reboot instead of failing immediately like it does on Linux. Unfortunately, even if it does work on Windows when the modem is connected, we really need this to work on Linux.

Some additional info on my setup and environment:

Mono version:

$ mono-sgen --version
Mono JIT compiler version (tarball Tue 02 May 2023 03:54:08 PM CDT)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
	TLS:           __thread
	SIGSEGV:       normal
	Notifications: epoll
	Architecture:  armel,vfp+hard
	Disabled:      profiler,debug
	Misc:          softdebug 
	Interpreter:   yes
	LLVM:          supported, not enabled.
	Suspend:       preemptive
	GC:            sgen (concurrent by default)

Mono installation info:

The executable “mono-sgen” is installed at: /usr/bin/mono-sgen and mscorlib.dll is installed at: /usr/lib/mono/4.5/mscorlib.dll

I’ve also tried moving the “mono-sgen” executable to ~/mono-runtime like the instructions say.

Current modem firmware version info via the “ati9” command:

2022/11/02 00:58:46
IMEI-SV: 3547205101606312
Legato RTOS: 22.10.0.FreeRTOS.w43 2022/10/19 09:57:37
atSwi: 22.10.0.FreeRTOS.w43
UBOOT: 01.03
Apps: RKAPP_03_02_00_00_24141_003__8c58020c3faa979ee7380bc905d0267fc2aed66e
MAC: ALT1250_03_02_00_00_24271_FW
PHY: 12.50.312573
PMP: 312547
AISE: ISE2APP_00_00_00_09

FPuK1: 1B993663
FPuK2: 25DF28C5
MCU-Disable: 1


Any help would be much appreciated.


Hi @anthony1,

Based on your description, do you want to downgrade from firmware to 5.4.10?
Sierra always encourages their customers to use the latest firmware on the module to update new features and improvements as well as include the latest bug fixes. Therefore, please consider not downgrading to the older firmware.


Hi @jerdung ,

Yes, I was attempting to downgrade the firmware in this case, but only for the purpose of testing the firmware upgrade procedure. Once I’ve ensured I can perform the firmware upgrade, I plan to use the latest Sierra firmware version.

Thank you,