HL7688 Firmware Archive

I’m having an issue with some hardware running the current 2.15.1 firmware on the HL7688. The same hardware works just fine with a HL7688 running 2.10.4.0. I’m sure we can address this in a firmware update to our hardware but that’s going to take some time and I’m in a bit of a crunch right now to say the least.

Is there an archive for older HL7688 firmware releases where I can find the 2.10.4.0 firmware release I’m looking for?

Hi @matt3,
Please get attachment for the HL7688_(AT&T)-RHL7688.A.2.10.4.0.151600.201610111555.x7160_1.zip (114.4 KB) . Let feel free share any concerns you have and help us tick Solution if the information is useful to you guy
Thanks

Thanks for the ZIP Vianney but I’m not having any luck getting the HL7688 to accept the DWL files.

I’m not very familiar with the process to bear with me. I’ve been using the below AT commands to try uploading the firmware to the unit. The process goes through without any ERRORs but after the update when I check the firmware version on the module, I can see it hasn’t been updated. I’ve tried with both “hl-fota-full_HL76XX_from_A.2.10.dwl” and “revhl-fota-full_HL76XX_from_A.2.10.dwl” with the same result.

AT+WDSI=4095 //enable +WDSI indication
AT+WDSD=932424 //size of FW.dwl file
//Send xx.dwl with HyperTerminal->SendFile->“1K Xmodem” protocol
+WDSI: 3 // downloaded, waiting to install
AT+WDSR=4 //install the package

I also notice that the DWL files in the link you sent are very small, around 50KB, where the DWL available on the website for 2.15 is 19MB.

Would there happen to be a self-contained EXE installer for this firmware available to eliminate any mistakes on my part?

Probably that is delta dwl if the file size is so small

That’s not what I was hoping to hear.

Hi @matt3,
Please get the attachment for HL7688 2.10.4 exe (Since the forum limits maximum size 4096k so I slit the file. Please remove .z at the end of each file then join them).
RHL7688.A.2.10.4.0.151600.201610111555.x7160_1_signed.7z.001.z (4 MB) RHL7688.A.2.10.4.0.151600.201610111555.x7160_1_signed.7z.002.z (4 MB) RHL7688.A.2.10.4.0.151600.201610111555.x7160_1_signed.7z.003.z (214.2 KB)
Alternately, you can access the link to download dwl full file which includes 2.10.4 FW. The procedure should be same below

Tell me if you have any concerns and help tick Solution if the information is useful to you guy
Thanks

I was able to use the EXE and it worked great! I really appreciate it.

I also tried downloading the DWL but I get a “Forbidden: Access is denied” message.

For troubleshooting purposes, would you be able to also supply the firmware releases between 2.10.4.0 and 2.15.1. As far as I can tell, those releases were 2.11 and 2.13.

Thanks again!