HL6528RD strange behavior using KHTTPGET command

I have a strange behavior using HL6528RD (the firmware is the last available one, from mid 2018).
I set the parameters for the KHTTPGET command, I do some KHTTPGET requests and after some requests (around five or less), the modem sends on the UART ‘CONNECT’ but stops there and don’t send the server response or the EOF pattern.
When I put AT, answer is ‘OK’, when I try to send another KHTTPGET request (even those who previously worked), it says ‘ERROR’. The only way I found is then to reset the modem and do everything once again. I tried to just send the connection parameters again, but the KHTTPGET request still sends ‘ERROR’
Is there a way to ‘unlock’ the KHHTPGET error and avoid reset? I also tried ‘ATZ’ with no improvement.
Do you think that I should put a long delay after getting the EOF pattern or something like that to give more time to the modem and avoid some internal miscalculation ?
Thanks !

Hi alzias, could you send your full AT logs?

I did some other tries and found that the issue was that spaces were not supported in the KHTTPGET sequence, even if they were allowed in my web browser. So my issue is till now solved.