Help on firmware update MC7455


#1

hello experts

I am bit very sad about MC7455 modem. i am unable to update the firmware for the MC7455 modem to the latest V.02.24.05.06

when i try to update to V.02.24.05.06 it still gives me error FAILED to switch BOOT and HOLD mod

can someone please tell me i am unable to put device in boot and hold mode using AT commands
i tried with putty COM25 and COM23 at baud rate of 9600 and 115200 both did not work i mean i cannot see any at command been accepted on these ports

  • by the way sierra support engineers( FAE from UK) do not know why this is happening we had a long conversations for nearly 6 months and they do not know why this happens.

Regards


#2

Hello,

You’ve installed two (2) Snapdragon modules and believe installed on HP notebook. Have you tried remove HP lt4120 Snapdragon X5 prior to install latest firmware for MC7455 ?


#3

Hi,

Just use a terminal tool or putty , and try to connect to COM port 24 at 115200bps.
Then issue at!boothold .
Then run the new FW and see

Regards,
Ud


#4

Just to follow up on Ud’s comment. He is assuming (probably correctly) that Windows has assigned the AT command port from the unit to 24 (since it is between 23 and 25. The definitive way to determine this is to right click the ‘Sierra Wireless Snapdragon X7 LTE-A WWAN Modem’ under modems and its properties to double check the port number then open a terminal on this.

Regards

Matt