GSM bugs or what?


#1

I take 2 new gr64 modems and start experiments using Windows Hyperterminal on both. Calling modem as master, answering modem as slave. I’ve changed default settings on both modems:
at+ipr=9600, ats0=1, at+ifc=0,0,1, at&d0.
Revisions:
*EIDSUM: GR64001/55 400 07W19 R3B GR64 “GR64/30”

1st bug.
After connection set up (both answered CONNECT 9600) i send nothing in line. After 2-3 minutes master or slave modem prints NO CARRIER and disconnects (answer zero on at+cpas). Other modem stays in connection for a period of at least 20 minutes until I send him manually +++AT and then ATH. After accepting ATH modem thinks about 1-2 minutes and prints OK (after this answers zero on at+cpas).
But if I disconnect modems manually using +++AT and then ATH, both modems prints NO CARRIER immediately and all OK - I can set up a new connection immediately.
It seems if one modem lost a connection, 2nd modem stays in line for a undetermined time. It is a modem bug or what?

2nd bug.
Send a command ATD to master and wait. Sometimes slave modem don’t prints RING. Аnd master prints nothing. Send a +++AT to master modem, get an OK answer. Send at+cpas, get 3 (ringing state). Send ATH and modem hangs up (for a 1 hour period at this time). I typing AT-commands in hyperterminal and see neither reaction no my characters. It is a modem bug or what?

Or may be this device only for GPRS and its GSM stable working not guaranteed?
Or may be exists a new firmware update? I can’t find it on this site. Anyone send me a link to it, please.


#2

I’ve updated my modems by R5A fw, found on this site, but nothings changed.
After powering modems on I can made 2-3 successful connections, until next of them finishes when one of modems lost it (only one! master or slave). Then I manually disconnect second modem by +++AT and ATH.
After that both modems reporting failure cause 16 on at+ceer, and zero on at+cpas.
Dial again. Got a No Dialtone on master modem. And failure case 25 (“Pre-emption” in manual. Who knows what does it mean?).
Dial again. Waiting 5 minutes. Master modem prints nothing. Send him at+cpas and got 3 as answer. Send him ATH and got a modem hang up. Only power switch helps.

Does anybody use GSM on GR64?


#3

This could well be a network issue.

Have you tried the same experiment with other modems on the same network?

Have you tried the same experiment with the same modems on other networks?


#4

Yes, I will repeat an experiment on a pair of mc35i with the same sim-cards.
But some of our customers who living in other region (about 3500km distance from me) has similar problems with gr64. Although they has the same GSM provider :wink:


#5

New results with a pair of Siemens mc35i.

One of modems continues to disconnect like with pair of gr64. And another holds connection. So it seems a bug of GSM provider.

But if I disconnect 2nd modem manually and try to dial to it (or just wait 30 minutes, until GSM provider closes connection by time limit), my dialing modem returns NO CARRIER or BUSY for a period of 3-5 minutes, and establish a successful connection in the end. Unlike gr64, which can not establish a connection after first time, when one of modems lost his connection, and even hangs up after several attempts. Until someone reboots him.

It’s very sad…