+++ and +++AT Breakout of GPRS Session


#1

Help Please, I am using the GS64 to call a central PC server to get updates. I have used both VB and Hyperterm to test commands before setting in Micro, and have hit same issue both ways. I get a connect from the GPRS session and can transfer data, but then cant break out using the +++ or +++AT. I wont have DTR on the final ap, but have it on the PC, but this doesnt seem to do anything anyway. Only way out id a full power down reset of modem at moment.

Thanks


#2

I have the same problem in a Linux environment on a Wavecom Q2686.
I’m using microcom to talk to the serial port. I setup a gprs session wait for the binary data to start flowing. At that point I’m successful in stopping the data from flowing by entering ‘+++’. I get OK from serial port and then a NO CARRIER.
After that I’m unable to write anything to the serial port.

Have you found a solution yet??


#3

Don’t know if you have sorted your problem out, and I have not tried GPRS yet. But I have found that you need to send +++at followed by a carriage return to enter command mode.
It would appear that it is case sensitive.


#4

My problem was that my linux embedded environment does not support DTR/DSR lines to the modem.
I solved the problem by issuing a AT&D0&S0 before starting the data session.