Serious issues with data calls and low radio signal strength


#1

Hi

I have a problem with data calls where i am unable to hangup one of the modems if the other looses GSM connection while the data call is in progress.

Let’s call the calling modem ‘A’ and the receiving modem ‘B’. I have tried the following conditions:

V.110 protocol and old type with long handshake.
The problem occurs both with OpenAT software enabled and without.

Modem A makes a data call to modem B. They both write CONNECT 9600 and are connected. Suddenly modem A or B looses its GSM connection (due to very bad signal strength) and writes NO CARRIER. However the other modem does not know that the connection has broken down. If i write ‘+++’ on the modem that still thinks it’s connected, then i can write ATH but nothing happens. The modem still flashes the FLASH LED fast to indicate a running data call. Hyperterminal does not answer with OK after the ATH. So i am not able to stop the call anymore. No other AT commands gives any response. The only command that works is AT+CFUN=1 which then restores the modem.

How do i get the modem to hangup the connection when this happens?


#2

You can use “AT+WAC” to hang up the connection… but still we should look into the problem more… this ideally should not happen… By the way, which firmware are you using…???


#3

Thank you for your response.

I have tested the +WAC command as you requested, but to no success. We are still able to create the above mentioned situation by removing the antenna from one of the units.

When it happens, the only solution to get it to hangup is to restart the modem. Removing the SIM card does not help either, it still blinks fast as if it has an active call in progress.

We use firmware version 7.3


#4

doesn’t it time-out eventually?


#5

You mean no AT command works…?? which means the module is in a hung state… if AT command works then you should get out of it thru “AT+WAC” …

Correct… it should time out…


#6

Sometimes AT commands work, sometimes not. AT+CFUN=1 always works. AT+WAC does nothing else but write OK. The Flash LED still keeps blinking fast and you cannot make a call with ATD as the modem still believes it has a call in progress.

Remember that this happens with or without the OpenAT software running.

No, we have not experienced it timing out. Though we have seen that sometimes we can get it back on track by unplugging the SIM card. However, this rarely works.


#7

How long have you waited?


#8

We have never waited more than 20 minutes. But i don’t see the relevance in this as a timeout still does not solve the problem that wavecom modules cannot hangup the connection. It must be a bug in the wavecom module as i have never experienced this with a normal GSM mobile phone.

We have also tried this with voice calls which produces the same problem.


#9

The relevance is this:

The signalling is a 2-way process between the mobile and the BTS; when the signal is lost, the module may well be waiting for something from the BTS - so there will be some kind of timeout before it realises that it is not coming!

It would be expected that the timeout would be longer than the normal process for clearing a call; so, if you were just being impatient, you might think that the module was “hung” - hence my question as to how long you had actually waited.

But 20 minutes is definitely not right!


#10

You should get your distributor or Wavecom FAE involved - they will be able to tell you how to get more detailed trace out of the unit to see what’s actually going on…