GL7812 - it is not detected by system (Windows 10) and it couldn't register

Hello, I couldn’t find a similar topic to that one.

I have made the setup exatly like in manual:

  1. SIM card is insterted correctly.
  2. Given power is between 6-24V a max current is set to 1A
  3. Modem is connected to laptop device through SERIAL-USB cable
  4. Device (or let say the connector) is detected by one of the ports.
  5. I am not able to send commands to that device using PuTTY software.

After that LED lights continuously, which means it didn’t register.

I have made second setup (I didn’t see an example of that in manual). I used the microUSB Port instead of SERIAL and only thing thath changed is that the device is not detected by Windows, on any port.

I eliminated the problem with SIM card, because it works with different model (I don’t remember which model, but i can say that is USB powered only).

I appreciate any help with that.

Hi @szymon.czapla,

Welcome to our community!


Hi, thanks for the answer

  • I’ve tried that and I can’t even type there, which means ther is no connection with it

  • Yes, we have another GL7812 and it acts the same

  • I saw that section. Nothing of it was helpfull

Whats weird for me is when I connect the modem through microUSB port then nothing is really happening, which probably means that in the first scenario using SERIAL connection the detected device is actually an adapter SERIAL-USB.

Hi @szymon.czapla,

Have you tried setting the baud rate to 9600 bps or 115200 bps?
In case the issue still occurs, try another method by using a different serial cable to see if the issue is coming from the cable.


hi @jerdung, the baud rate change from 9600 to 115200 worked for us, thank you for your help! :wink: