MC7304 Driving me nuts!

Hi All,

First time here and we have been using Sierra for years - that’s a good thing.

We build industrial PC’s and have been using the MC7304 for our Linux boxes and we never see them again.
However, I have a customer that wants our machines in their railcars with Windows 7 Pro x64 and the MC7304.

On a clean install of Windows 7, I installed the latest USB drivers (4581) and rebooted Windows. I can then connect to the internet manually dozens of times.
However, when I enable auto connect on start-up (Skylight) or native Windows, that’s when things get weird. The modem gets detected, it connects to the internet briefly, falls off the internet, the dreaded 'no broadband device detected" pops up. It does this cycle for about 5 minutes. Then completely disappears from Device Manager.

I have tried different PC’s and 3 or so different MC7304’s - I am close to going nuts. Can anybody shed any light on what is happening?

Thanks a million in advance!

Hello ,
Please uninstall all the sierra drivers other than MC7304 drivers if installed and reinstall the MC7304 driver. Try on latest version of Skylight available.

Thanks & Regards,


On which hardware flatform ? Lenovo, DELL or other branded models ? Have you tried to taping pin #20 ? Just to make sure that MC7304 module (hardware) is always on.

Hi Guys,

Thanks for the replies.
Yes, have tried uninstalling all drivers, skylight etc… no difference.

Ok, I have identified the problem and when it happens - but not the root cause.

I have an older MC7304 that was in one of our other PC’s SKU: 110241.
All of the new modems I received are SKU: 1103054

The older model (110241) works flawlessly, every time.
When I install the newer modem (1103054), there is no issue “until” I enable auto connect either through Windows WWAN or Skylight. As soon as I do this the modem will connect and disconnect until what I think Sierra have described as SED (Smart Error Detection). Once this happens the only way of getting back in is to run a firmware update and quickly uncheck the auto connect.

I have tested this a dozen times with the older model and the newer model - and it is consistent. I need to find out what is different about it.
I have emailed support about this but heard nothing back.

Anybody have any idea what is going on?

Thanks in advance!