MC7304 Airprime Win10


#1

Can,t get MC7304 to work on Windows 10: (no internet connection) works fine on Linux. straight out of the box.

Event message: … Device USB\VID_1199&PID_68C0&MI_0c\6&26fa6dde&7&000c was not migrated due to partial or ambiguous match. … Although I am not sure it matters.

Thanks Alan


#2

Hello @Alstratt
basic check: have you install the latest Windows Drivers?
https://source.sierrawireless.com/resources/airprime/software/airprime-em_mc-series-windows-drivers-qmi-build-latest-release/

Regards,


#3

The problem seems to be Win10 will not allow allow older drivers to be installed.!


#4

MC1


#5


#6

From your screenshot, it looks like you are using a generic driver. In my case with Sierra Wireless drivers, the network interface is exposed as “Sierra Wireless Mobile Broadband Network Adapter” with “Sierra Wireless Incorporated” as manufacturer

In your case, this is a Network Adapter from Microsoft.

Can you confirm you installed the driver from the link on my previous post?


#7

Apparently Win10 is blocking install of Sierra drivers, I have tried many times including uninstalling device, just keeps selecting windows drivers.


#8

It looks like I overlooked a bit your screenshot.

My module is configured as a QMI device and in your case the device node is 1199/68C0_MI_0C which indicates your module is configured as a MBIM device, in your case you don’t need to use any specific driver aside from native Windows’. It is normal to see “MC7304” as the name for the network interface

If I configure my module as yours, the network interface also shows up as “MC7304”

Now back to initial problem why do you say that the device is not working? Whether you use QMI or MBIM mode, you should see the cellular modem in the network interfaces:

Do you see such device on your side?


#9

Yes here is snip. No internet access.

Worked straight out of the box on Linux.


#10

Hi

After much uninstalling and reinstalling, fiddling with drivers it suddenly started working.

Thanks for the help Alan

ScanPark Ltd

Portable ANPR

Tel: 01565 723024 Mobile: 07787 403528. e:mail alan@alanstratton.co.uk


#11

good to hear.
In this case can you mark this post as resolved?
Thanks,


#12

Hi

I spoke to soon, stopped working.

I guess it was a windows update.