EM7305 Windows 10

I am using the EM7305 on a Windows 10 laptop with the Airprime M.2 USB 3.0 development kit. I have installed the latest relevant Windows drivers, AirPrime EM_MC Series Windows Drivers QMI build 4743. However, the EM7305 always seems to use the Generic Mobile Broadband Adapter driver. It is installed as the EM7305 under the network adapter section in device manager and a Sierra Wireless location sensor is installed in the sensor section. My goal is to expose the diagnostic (DM), AT, and NMEA interfaces. I have assumed these will be exposed as COMM ports. I have successfully exposed these interfaces in Linux and have confirmed that USBCOMP is configured to enable all of the interfaces. Can someone provide guidance as to how to force these interfaces to be exposed on Windows 10? Thank you!


I’ve the same scenarios for my EM7455 when I’ve installed latest QMI drivers (4743) under Windows 10 where only shown Network Adapter and Sierra Wireless Location sensor. The problem was resolved by re-installed QMI drivers (below release) by supply manually “USBCOMP=8”.

Thank you!

That was exactly what I ended up doing. The steps I took are below.

  1. Uniinstalled all Sierra Wireless drivers.
  2. Installed GenericDriverSetup_Build4581.exe
  3. Made sure modem was disconnected.
  4. In the DriverPackages dir I ran “DriverInst.exe USBCOMP=8” from an Administrator command prompt.
  5. #4 seemed to be critical to prevent the Sierra Wireless drivers from setting the USBCOMP back to 9 (MBIM only). The swi_setusbcomp.pl script floating around the web has been very valuable to check and set the desired USBCOMP mode on an Ubuntu machine.
  6. The default EM7305 Windows Generic Broadband driver is installed.
  7. Update the driver of the network adapter.
  8. Choose Driver => Have Disk => c:\Program Files(x86)\Sierra Wireless\driver package\driver\swg3kmdm00.inf
  9. “Sierra Wireless Incorporated” => “Sierra Wireless Mobile Broadband Network Adapter”

These are the exact steps that worked for us to get all ports accessible.


I did what radupontg3 explained
But the card in the network windows appears then desappears then appears and so on.
any advice for me?

I also facing the same situation, I also tried to connect EM7305 on windows 10 but my system does not recognize that also it shows an error dell error code 2000-0333, so I want a proper solution how can I remove this error as soon as possible.