EM7305 Connecting to the at Interface on windows

Hi,

I’ ve been asked to write a piece of software for the EM7305 on a windows machine,

Normally to connect to a modem I’d use AT commands on a serial port or the qmicll interface(if were on linux),
However on windows the EM7305 seems to only provide 2 serial interfaces, one for NMEA (which works but is not what im after), and a DM port(which i believe is a proprietary interface from qualcom),

Can anyone point me in the right direction on how to access the AT interface, or if it just doesnt have one, how to access this modem’s commandset some other way programmatically.

Ive tried looking at the documentation but the only reference to AT seems to be the generic AT reference command list which doesnt seem to specify any way to actually connect.

Hi,
Are you able to see ‘modem’ port in the ‘device manager’? If so, you can make use of it :slight_smile:

-Alex

Normally when you download the EM7305 Driver Package, make sure that there is a configuration.ini with the setup.

When you do, you have to modify it like this:

Then, you launch the setup, and restart your PC.
You’ll notice the modem, and the 2 com ports for NMEA GPS and DM Diagnostics in the Device Manger after the restart.

That’s it :slight_smile:

Hello everyone,

I’ve been experiencing the same ‘‘problem’’ and so far no succes, let me explain:

I have a Fujitsu Siemens E736 laptop, with EM7305 module, operating win10 x64.
The module works fine, latest skylight & drivers installed, internet acces ok, GPS is recognised by windows maps.
I use to have (on previous laptops with Sierra Wireless sensors) a couple of serial com ports in the device manager (like you mention in your post).
This was allowing me to connect various software to the GNSS/GPS, and use the nmea information.
However with this one I only have 2 devices : Sierra Wireless Location Sensor in the ‘‘Sensor’’ line, and EM7305 in the ‘Network’’ line…no com ports at all.

I tried to run the install package with the edited ini file described on your post, but no success.
Is this feature gone or do i have to make something to enable the com ports?

Brgds
Tristan