GL6100 Software upgrade

I have a GL6100 and I’ve tried to upgrade the firmware from 7.41 to 7.52 and now the modem only response is “BAD SOFTWARE”. Is there any way to fix this?


The latest software for GL6100 is R7.47 and R7.47.6, maybe you can try re-download the correct software?


Hi, thanks. Actually, I 've been trying to use the Hyper Terminal to send command to the unit, however no commands are accepted. I cant send new firmware files as well. Is that any type of reset available?

Which AT command you tried?
How about “AT”, “AT+WDWL?” and “AT+WDWL”?

I have tried all AT commands possible… But it continues to spit out “BAD SOFTWARE”

I have a GL6100. It shows +WDWL few minutes after powered up. This is whit port configured at 1800bps (on PC terminal) and no flow control. Using any other port speed it never answers anything.

Im using ClearTerminal and it allows file transfer throught XModem. The problem is i CAN NOT FIND the Open AT Firmware version 7.47 “.dwl” file (or older), that should be fine for this modem. Where can i download it?

It allow me to write “AT+WDWL” and the “-------” begin to show for file transfer.

Im able to download Firmware version 7.53 but the file transfers fails.

Does it comes with RS232? If yes, the best try is to use DWLWIN updater to re-download the FW.

Please install OpenAT Framework 2.3.2, after that you can download the latest firmware package.

Thank You.

I download that package and got it installed. Where in developer studio i connect to modem to download the firmware? i cant find that option.

After Developer Studio is installed, you can obtain the firmware package in “Package Manager”, the latest FW for GL6100 can be found inside “Open AT Application Framework” 2.37.6 or 2.37.0, of default repository.

Developer Studio also support FW download and it is inside “Target Management”, “Firmware” in “Status” view.

For sure, you can get the .dwl files (located inside “Embedded Software” folder, e.g. C:\program files\embedded software) and download the firmware using terminal application as usual.

Hope it helps.

Thanks for the answer.

In developer studio, i cant find “package manager”.

In “Help” - “Install new software”, theresá a default repository and does not show any open AT aplication frmework for donwload.

I gess the developer studio installed itself including only the latest version (open AT 2.52), that does not include any files for GL6100.

i dont see any “status” view in all developer studio.

in embedded software folder, i see some .ddwl files but nothing for GL6100 (com.wavecom.openat.ide.spm.fw.model. Inside there are files like R7.52.0_fxt009.dwl R7.52.0_sl6087.dwl R7.52.0_q2686RD.dwl

The one inside “Help” is used to update Developer Studio so not that one.

How about “Windows”->“Open Perspective”->“Other…” then open “Packages Manager” from there?
After that you can find and refresh “Default Sierra Wireless Repository”.

YES, im able to get firmware package 7.47.6 in there.

Thanks a lot. :smiley: