FXT009 CPIN and Error 10

Hi, I have two modems FXT009 installed on two differents customers. The two modems worked fine but, suddenly, at a different moment, the two modems had a problem to detect the SIM Card :

2014/11/17 11:18:25.537 - WaitFor: +CPIN:
2014/11/17 11:18:25.537 - Out:AT+CPIN?<0D>
2014/11/17 11:18:25.584 - In:<0D>
2014/11/17 11:18:25.584 - In:<0A>
2014/11/17 11:18:25.600 - In:+CME ERROR: 10<0D>
2014/11/17 11:18:25.600 - In:+CME ERROR: 10

I removed and replaced the Rogers Sim card and all was OK. Maybe this problem will come back…

What is the problem ?
It is strange that the two modems have the same problem. Is it a known problem ? Does this problem has been fixed by a new firmware ?
I use often the firmware version R7.45.5 , I think that the two modems have this firmware.

Thank you,


I have the same problem on :
FXT009 with firmware 7.47.4.
FX100 with firmware 7.53 WP13 and 7.53 WP18.
I use OpenAT framework (adl_simGetState() function).

Sierra has never provided any solution to this problem.
Generally with a power off/on cycle, the SIM card is recognized by the modem. But in some cases, even with several power off/on cycles, the SIM card is still not recognized, adl_simGetState() function returns ADL_SIM_STATE_REMOVED.
I don’t know if a simple reset of the modem is enough.

If you fall on this problem again, just remove and insert again the SIM card (with power ON), you will see than after inserting again the SIM card, the SIM initialization will be OK.

With modems in production, it is a real problem !
But as I said, no support from Sierra on this problem…


Thank you MichaG for your message.
OK… I hope that this problem does not occur more that one time per year, if not, for us it is not acceptable.
Maybe, I will try the last firmware R7.52 .
I will inform you if I have the same problem with this firmware.

If anyone has a better idea, I listen you.

Thank you,

I know that I can to reset the modem with CFUN=1.
But do the FXT009 have an another way to reset ? I reset more strong that CFUN ?
Some modems can use AT$RESET, but the FXT009 don’t have this function…

Thank you,