FXT 009 tries to register with wrong operator!


#1

Hi, all

We have a weird issue here. Only observed in one place with one particular antenna type.
Brand new units are connected there and modem fails to register. Different modem on same antenna and SIM card registers fine. Use different antenna and FXT009 will register as well. Signal issues? I thought too, but it is not.
I tried to run AT+CCED=0,1 command and MNC (Mobile Network Code) is wrong!!! Modem tried to register against wrong provider. No wonder it fails.

Now for the weird part – any attempt to force operator or radio rescan (at+wmbs or at+cops commands) will immediately find the right operator and modem will register happily. And fault is gone. Reboot or re-power the modem and it is happy registering.
The problem is that we have few hundreds of those deployed to a customer and this particular location happens to be their test lab, so they froze the deployment until we can figure out how to fix the modem so situation like that will not happen in the field.
At this stage, I got some logs and Sierra Wireless are looking at the problem. But any help in the meantie is greatly appreciated.
modem: FXT–0
F/W 7.45

Thanks,
Rudolf


#2

Could you please detail how did you know you’re trying to connect to the wrong operator, and how did you manage to solve it? I think I’m having the same trouble and I don’t guess how to solve it. Thanks!


#3

Hi,

AT+CCED=0,1 will show main cell environment and that includes operator ID. I my case it was wrong.
Problem is not solved yet – it is in the hands of Sierra Wireless at the moment. Seems that FXT-009 is experiencing quad-band autodetection problem when there is WCDMA signal on 850MHz band.

Rudolf


#4

I tried to use dualband configurations as my app worked on ancient non quadband modems. But the results remains the same…

It’s funny because I managed to get some examples working which do almost the same, and from time to time, my apps do work, but almost all time is spent doing connection.


#5

Before auto quad-band functionality was working, I implemented manual band hunt that worked pretty well.

Use AT+WMBS command to select a band
Wait 30s for registration
If no registration achieved, change to next band repeat

Worked fine. Obviously, band search would take time, but I only had to do it once per installation with some logic that remembered last state.

Rudolf


#6

In my case, changing band seems to be working worse, so if Sierra Wireless answer you with a workaround, please let me know.


#7

When my modem was trying to register to de network I tried to check quality of signal and returned 25,3. What does that 3 means? Documentation points me to a table I doubt I have… :blush:


#8

Hi,
The 2nd parameter refer to BER, bit error rate.
The table mentioned is available in 3gpp spec.

The signal looks very good, can you describe the exact problem and probably with AT log? Issue may look similar but it can be different case as well.