Won't register to network on specific band


#1

Hi there,

I have an MC8790 that won’t register to the network or rather won’t connect to an operator on 850MHz (UTRAN). Seems to be OK on GSM. Running out of ideas about what it could be. Have reset to factory default (at&f) although that doesn’t appear to change most of the band settings etc. Have another MC8790 that seems to work fine with same SIM and hardware. Using ALIX6 board running Voyage linux distribution.

Any thoughts or ideas appreciated.

ati
Manufacturer: Sierra Wireless, Incorporated
Model: MC8790
Revision: K2_0_7_35AP C:/WS/FW/K2_0_7_35AP/MSM6290/SRC 2010/03/04 17:37:08
IMEI: 358948011120704
IMEI SV: 16
FSN: C660511109310
3GPP Release 6
+GCAP: +CGSM,+DS,+ES
OK

SIM OK:
at+cpin?
+CPIN: READY
OK

Signal level OK:
at+csq
+CSQ: 24,99
OK

Band is set:
at!band?
!BAND:
0D, WCDMA 850
OK

Region has been set correctly:
at!custom?
!CUSTOM:
PUKPRMPT 0x01
MEPCODE 0x01
PRLREGION 0x03
PCSCDISABLE 0x03
GPSENABLE 0x01
OK

Modem see’s the operator (and even indicates it is the current operator selected):
at+cops=?
+COPS: (2,“Telecom NZ”,“Telecom”,“53005”,2),(0,1,2,3,4),(0,1,2)
OK

But:
at+cops?
+COPS: 0,0,“Limited Service”,2
OK

at!getband?
!GETBAND: No Service
OK

Cheers
Shane


#2

Hi,

When AT!GETBAND? is returning limited service,did you try to rest the module and try to set the ban manually using AT!BAND=02.

Please try with some other firmware(latest) on same hardware.


#3

Hi Rex,

at!getband is returning “no service”. It is at+cops? that is returning “limited service”.

I don’t understand why you suggest at!band=02. The at!band parameters are dependent on the region setting (currently 0x03) and 02 simply defaults to ALL in my case. Maybe you actually mean using at!gband to set the band mask in a bitwise manner?

Cheers
Shane